WordPress.org

Ready to get started?Download WordPress

Forums

Enhanced Link Attribution not working with Yoast Google Analytics 4.3.2 (1 post)

  1. towelsrus
    Member
    Posted 1 year ago #

    I have tried setting up enhanced link attribution using the Yoast Google analytics plugin and entering in a custom line of code as described in this article.

    http://support.google.com/analytics/bin/answer.py?hl=en-GB&answer=2558867

    Withought the code in-page analytics works fine. but with it it returns the following message.

    Problem loading In-Page Analytics
    We tried looking for a few common problems with your setup, but couldn't find what's wrong. Please try again later.

    This is the code loaded in the page header. Any ideas why its not working? I have enabled enhanced link attribution within analytics too.

    // Google Analytics for WordPress by Yoast v4.3.2 | http://yoast.com/wordpress/google-analytics/
    var _gaq = _gaq || [];
    _gaq.push(['_setAccount', 'UA-38678774-1']);
    var pluginUrl = '//www.google-analytics.co.uk/plugins/ga/inpage_linkid.js'; _gaq.push(['_require', 'inpage_linkid', pluginUrl]);
    _gaq.push(['_trackPageview']);
    (function () {
    var ga = document.createElement('script');
    ga.type = 'text/javascript';
    ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';

    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(ga, s);

Topic Closed

This topic has been closed to new replies.

About this Topic