WordPress.org

Ready to get started?Download WordPress

Forums

Enhanced BibliPlug
[resolved] [Enhanced BibliPlug] Fatal error (4 posts)

  1. gillespieza
    Member
    Posted 2 years ago #

    This plugin triggers a fatal error in \bibliplug_template.php on line 147

    Also, my server does not support the use of the php short-tag <? - is it possible that you could use the full <?php?

    http://wordpress.org/extend/plugins/enhanced-bibliplug/

  2. zuotian
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,

    This problem has been fixed in 1.2.7 release.

    Thanks.

  3. Broos
    Member
    Posted 1 year ago #

    I'm still having this problem when I installed the latest release

    Plugin could not be activated because it triggered a fatal error.

    Warning: require_once(/home/httpd/http/virtualhosts/_wordpress/wp-content/plugins/enhanced-bibliplug/bibliplug_query.php) [function.require-once]: failed to open stream: No such file or directory in /home/httpd/http/virtualhosts/_wordpress/wp-sites/www.inth.ugent.be/plugins/enhanced-bibliplug/bibliplug.php on line 45

    Fatal error: require_once() [function.require]: Failed opening required '/home/httpd/http/virtualhosts/_wordpress/wp-content/plugins/enhanced-bibliplug/bibliplug_query.php' (include_path='./:/home/httpd/http/flwi/includes:/usr/share/php:/home/httpd/http/flwi/include') in /home/httpd/http/virtualhosts/_wordpress/wp-sites/www.inth.ugent.be/plugins/enhanced-bibliplug/bibliplug.php on line 45

  4. zuotian
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Broos,

    Can you tell me a little bit more on your server setup? Are you using a wordpress MU installation with subdomain?

    Currently Bibliplug is under testing for MU with subfolder settings.

    I have a fix in mind, but I cannot replicate your error, thus cannot be sure the fix will resolve the issue. If you are comfortable with code, please try replace line 35 of enhanced-bibliplug/bibliplug.php

    define('BIBLIPLUG_DIR', ABSPATH . 'wp-content/plugins/enhanced-bibliplug/');

    to

    define('BIBLIPLUG_DIR', WP_PLUGIN_DIR . '/enhanced-bibliplug/');

    Or, I can send you a patch for the plugin.

    Thanks,
    Zuotian

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic