WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] encrypt cookie warning not going away (6 posts)

  1. Paul Wright
    Member
    Posted 4 years ago #

    Hello,

    I upgraded from MU to 3.0 beta-1 and I get the "Warning! WordPress encrypts user cookies, but you must add the following lines..." warning telling me to add the lines to my wp-config.php file.

    The issue is that I already did that during my MU install. The line is indeed in my wp-config file and even removing it then adding the new one didn't solve the problem.

    Paul

  2. Paul Wright
    Member
    Posted 4 years ago #

    seems to have been duplicated, sorry

  3. Are you sure you added all of the lines?

    You should have 4 keys and 4 salts.

  4. Paul Wright
    Member
    Posted 4 years ago #

    Hi!

    Your suggestion got me thinking.

    The problem was that I upgraded from WMPU and reused my wp-config.php file (with a couple adjustments).

    I had used the WPMU secret key generator which was 5 entries instead of 4 for the authentication keys.

    Once I changed those keys to the regular wordpress ones I still got a warning, but instead of giving me one salt, it gave me 4.

    So, like you said, I now have 4 keys and 4 salts, instead of what I had for my WPMU install which was 5 keys 1 salt.

    Thanks, it's fixed.

    Paul

  5. sassymonkey
    Member
    Posted 4 years ago #

    I would like some more detail on your solution. I'm having a similar problem and cannot get my admin pages to stop showing an AUTH encrypt warning.

    I successfully installed a multisite WP 3.0 version on one host and then copied verbatim to a second similar host but keep getting the problem.

    This is to say I had a working wp-config file in one instance and apparently not in the next almost identical install (differences are only in database name, username, and password of wp-config, plus the root URL instances found in the multisite section of wp-config and in the DB).

    I'm using the 4 line code suggested by the randomly generated warning as well as trying what is generated at https://api.wordpress.org/secret-key/1.1/

    You can read all the details here: http://wordpress.org/support/topic/426579

  6. sassymonkey
    Member
    Posted 4 years ago #

    @ipstenu at the other thread just helped me discover the problem. I'll repeat the solution here for others:

    There's a KEY 4 line block AND a SALT 4 line block.

    Having only ever seen the KEY version before in working with non-multisite WP, I did not notice a difference.

    In other words, I was copying over the SALT with the KEY since I didn't know there's a difference.

    There are 8 lines total that need to be included in the wp-config file on multisite consisting of both SALT and KEY codes.

Topic Closed

This topic has been closed to new replies.

About this Topic