WordPress.org

Ready to get started?Download WordPress

Forums

Encoding problem when posts sharing on facebook (after update to 3.0) (11 posts)

  1. wiseprt
    Member
    Posted 4 years ago #

    Hello there,
    In all of my blogs i have updated to version 3.0 "thelonious", have problem when i try to share a post on facebook (via facebook connect / addthis plugin even with a simple url copy-paste). All the characters are in the greek language (encoding UTF-8) have encoding problems!

    Any Suggestions?
    Thank you.

  2. wiseprt
    Member
    Posted 4 years ago #

    anyone? plz guys...

  3. ktsixit
    Member
    Posted 3 years ago #

    I have the same problem. I am using greek characters and utf-8 encoding too.

  4. mienque
    Member
    Posted 3 years ago #

    I also have the same issue. I have tried hours to hours to fix it but not successed.

  5. mikkohei13
    Member
    Posted 3 years ago #

    Had similar problem. Converting all my template files to UTF-8 without BOM (with Notepad++) solved this.

  6. bouropoulos
    Member
    Posted 3 years ago #

    I have the same problem with my posts. I tried converting my theme's template files with Notepad++, as mikkohei13 suggested, but nothing happened. Should I convert the default theme templates as well?

    This is a very annoying problem and I am not sure if it is a WordPress or a Facebook problem... please help!

  7. Merras
    Member
    Posted 3 years ago #

    Same problem with Hungarian characters.

  8. Joe
    Member
    Posted 3 years ago #

    Notepad++ is a great text editor, especially for developers working with code. Get it here:

    http://notepad-plus-plus.org/download

    In your WordPress installation files, browse to your themes folder:

    example.com/blog/wp-content/themes/mycustomtheme/

    Inside this folder, open all your files ending with *.php using the Notepad++ program. In the menu bar at the top, look for:

    Encoding > Convert to UTF-8 without BOM

    Save the file. Repeat with all .php files. Upload all your edited files back to the server via ftp if you downloaded them locally first.

  9. bouropoulos
    Member
    Posted 3 years ago #

    Thanks Joe!!!

    I was desperate, I've did it once more after your comment and IT WORKED!!!

    Thanks again...

  10. Joe
    Member
    Posted 3 years ago #

    Credit goes to mikkohei13 for the solution, I just spelled out the steps. :)

    Joe

  11. Merras
    Member
    Posted 3 years ago #

    The solution is not working, I converted all my template phps, the problem still exists.

Topic Closed

This topic has been closed to new replies.

About this Topic