WordPress.org

Ready to get started?Download WordPress

Forums

Encoding problem after update to version 3.5.1 (14 posts)

  1. Ayman
    Member
    Posted 1 year ago #

    Hello,

    After updating to WordPress 3.5.1 some strange characters started to show up in posts titles replacing special Italian characters for example the (è) is showing as black diamond with white (?) in it...
    It's more than a week and I'm trying to find a solution to this problem but no luck
    I folowed a lote of suggestions that indicates deleting the define('DB_CHARSET', 'utf8'); from wp-config.php but in my case doing that just made it worse...

    Informations Of what I have now:
    1. the database collation is set to: utf8_general_ci
    2. The html output is showing <meta charset="UTF-8">
    3. Itried to check the html output by w3 validator but I got this error blocking the validator: `Sorry, I am unable to validate this document because on line 616 it contained one or more bytes that I cannot interpret as utf-8 (in other words, the bytes found are not valid values in the specified Character Encoding). Please check both the content of the file and the character encoding indication.
    The error was: utf8 "\xE2" does not map to Unicode`

    Any Idea suggestion would be very appreciated

  2. clickmac
    Member
    Posted 1 year ago #

    deleting things from the wp-config.php may as well shut down your wordpress site. return it back to the way it was, or completely re-install it.

    then try deactivating all of your plugins one by one, to see if it's a plugin issue.

  3. Ayman
    Member
    Posted 1 year ago #

    I already have my wp-config.php file as it was and everything else on the website is working it's just the encoding problem.

    then try deactivating all of your plugins one by one, to see if it's a plugin issue.

    I will try that

  4. clickmac
    Member
    Posted 1 year ago #

    ok. let's see what happns

  5. Ayman
    Member
    Posted 1 year ago #

    I tried disabling all plugins but that didn't change anything.
    Any Idea?

  6. clickmac
    Member
    Posted 1 year ago #

    what's the link to your site?
    to the problem page itself

  7. Ayman
    Member
    Posted 1 year ago #

    The problem is showing up only on the home page on a non featured articles .
    Here is the link: Home Page

  8. Media X
    Member
    Posted 1 year ago #

    I don't see anything wrong with your post titles. For example:
    Bergè da Centovetrine... shows the è just fine.

  9. Ayman
    Member
    Posted 1 year ago #

    Have a look at this 2 titles:
    Quando il bodyguard diventa virtuale…&#...
    OR
    Donne tagliano il traguardo della maratona &#...

    You will not see the problem with featured articles you will see it with titles of articles that are under the featured articles.

  10. Media X
    Member
    Posted 1 year ago #

    It looks like if your post excerpt ends up with quotation marks it gets badly formated. The best solution would be to contact the template author. We can offer support only for themes distributed on WordPress.org

  11. clickmac
    Member
    Posted 1 year ago #

    yes it seems that way, good spot @Media X

  12. Ayman
    Member
    Posted 1 year ago #

    I know that the themes support here is only for themes distributed on WordPress.org
    It's just that I didn't think It was a theme problem.

  13. Media X
    Member
    Posted 1 year ago #

    Ayman, did you switch to the default theme and check if the titles and excerpts are working properly ?

  14. Ayman
    Member
    Posted 1 year ago #

    @Media X , @clickmac
    Thanks for your response and sorry for my late reply.

    Anyway, after digging more into it I arrive to the conclusion that the "Smart Quates" that wordpress are the problem... but the only thing is that I appeared just now and never before, so I kept digging more till I discovered that some of my database tables were created using latin1_swedish_ci insted of utf8_general_ci.

    So I decided to re-install the website from scratch and that's still in progress.

Topic Closed

This topic has been closed to new replies.

About this Topic