WordPress.org

Ready to get started?Download WordPress

Forums

Encoding change messed up WordPress (3 posts)

  1. gargle
    Member
    Posted 4 years ago #

    I got annoyed by seeing lots of ? instead of some characters so I decided to try to "guess" encoding. I changed it first to latin2, then latin4 and utf-7 (all done inside settings->reading). Last change made me unable to save eny changes to settings giving me

    Your attempt to edit your settings has failed.

    it has also disabled Visual editor (but it still has check flag in settings), makes similar error when saving/publishing post and gives blank page after submiting comments.

    I realy don't know what to do, didn't mess around with anything because I didn't want to make even bigger mess. Some tutorials and answers I found only give temp solution or fix one of the issues I have.

  2. stevejohnson
    Member
    Posted 4 years ago #

    If you are unable to change settings through the Dashboard, you'll have to do it directly in the database using a tool like phpMyAdmin.

    In the wp_options table find the line with option_name = blog_charset. Change the value to UTF-8. That should at least allow you to use the dashboard again.

  3. gargle
    Member
    Posted 4 years ago #

    It worked! Everything went back to normal. Thank you!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.