WordPress.org

Ready to get started?Download WordPress

Forums

Enabling xmlrpc.php broken (2 posts)

  1. sow
    Member
    Posted 3 years ago #

    I have WP 3.01 running a website using Atahualpa with Buddypress on a linux host. Having been unsuccessful trying to login from an Xperia X10 phone with WordPress Android I checked Settings-Writing to make sure that XML-RPC was enabled.

    It wasn't enabled so I set the checkbox and saved. On saving I was taken out of Settings-Writings to a 404 screen. Opening Settinsg-Writing again I see that the enabling checkbox is not set.

    xmlrpc.php is however present in my root folder /public_html/ along with index.php and wp-config.php etc. Permissions are set at 644 and I have tried 666 with no luck. NOTE: There is no problem setting the adjacent Atom protocol.

    I have noted that there is a different version of xmlrpc.php in one of the buddypress folders.

    Any ideas?

    Thanks

    Will Chapman

  2. There could be a conflict with a plugin or theme functions (they can affect the admin panel).

    Try deactivating all plugins (including BuddyPress). If that resolves the issue, reactivate each one individually until you find the cause.

    If that does not resolve the issue, try switching to the Default theme (WordPress 1.5 - 2.9.2) or the Twenty Ten theme (WordPress 3.0 and higher) to rule-out a theme-specific issue.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.