WordPress.org

Ready to get started?Download WordPress

Forums

P2
Enabling shortcodes (7 posts)

  1. tshirtfiend
    Member
    Posted 10 months ago #

    I have a .org install of WP, running with the P2 theme.

    I'm trying to use the various shortcodes, including the ones that Jetpack enables. It seems that they are being processed somehow and not usable in P2.

    Can anybody shed light on how this processing is happening, and how I might enable them?

    Thanks.

    http://wordpress.org/themes/p2/

  2. valuser
    Member
    Posted 10 months ago #

    I THINK shortcodes will work everywhere if you add this code to functions.php

    add_filter( 'widget_text', 'shortcode_unautop');
    add_filter( 'widget_text', 'do_shortcode');
    
    add_filter( 'the_content', 'wpautop');
    add_filter( 'the_content', 'shortcode_unautop'  );

    Perhaps!

  3. tshirtfiend
    Member
    Posted 10 months ago #

    @valuser: Thanks for responding.

    Doesn't seem to work for me. I've tried:

    • Shortcodes from the front page editor
    • Shortcodes from the dashboard in the "visual" editor
    • Shortcodes from the dashboard in the "visual" editor

    No luck getting anything to work. Could the functionality be stripped out somehow?

  4. valuser
    Member
    Posted 10 months ago #

    beats me, i'm afraid!

  5. tshirtfiend
    Member
    Posted 10 months ago #

    That's a bummer. I took a quick look at the source, but some of it is above my head. I've seen other people with the problem, but no solution.

    I can't imagine why it wouldn't just work.

  6. Jay Versluis
    Member
    Posted 10 months ago #

    I've just tried using the Archives shortcode from Jetpack, and they seem to work fine for me in P2. They work from the back end in the visual editor, as well as when posting from the front page.

    Have you activated the Shortcode Embeds option in Jetpack?

  7. tshirtfiend
    Member
    Posted 10 months ago #

    Part of the issue seemed to be with Jetpack. I would activate it, and then it would turn off automatically somehow.

    I was able to connect it to WP.com, which seems to be the key. It's working now.

    Thanks for the help guys.

Reply

You must log in to post.

About this Theme

About this Topic

Tags