WordPress.org

Ready to get started?Download WordPress

Forums

Enabling Sending Referrers. (86 posts)

  1. Amiantos
    Member
    Posted 9 years ago #

    Is there a safe and fool-proof way to wipe out your WP install (files and MySQL and all) and retain all the posts? At this point I'm desperate to see if I can get it working again... I suppose I could back up the relevant tables using PHPMyAdmin... God, that would be a pain though.

  2. jose
    Member
    Posted 9 years ago #

    macmanx, here i have two computers, one with Linux and other with xp, and several browsers. All the time I go to the error "Sorry, you need to enable sending referrers, for this feature to work."if attempt to activate.

  3. RustIndy
    Member
    Posted 9 years ago #

    Sounds like it's probably a server issue then. That test blog here is on Apache 2 with PHP 5 and MySQL 4.1. Some of the other blogs I host are under IIS with PHP4 and MySQL 4.0 (I was young and stupid, what can I say - besides, WP1.2 doesn't like PHP5, and I don't like forcing PHP4 to cooperate with MySQL 4.1).

    OK, last steps before you call your hosts and find out why this happens:

    Route 1
    --------
    1) backup your WordPress installation to your hard drive
    2) delete the /wp-admin and /wp-includes folders
    3) in the root folder, delete the wp-settings.php file
    4) upload all those files/folders from an original WordPress installation archive (use the same version that was there before)
    5) test

    Route 2
    --------
    (only for extreme rebuilding)

    1) backup your WordPress installation to your hard drive
    2) backup your database
    3) delete EVERYTHING in your wordpress folder except /wp-config.php
    4) upload WordPress from the original files available on the site here, preferably the same version you were using before
    5) test it

    Route 3
    --------
    (because sometimes you just need a fresh database)

    1) backup WordPress and your database
    2) if possible, create a brand-new database, and upload WordPress to a brand-new folder
    2a) if not, then delete both completely, then create a new database and new WordPress folder
    3) upload and install WordPress
    4) test

    Good luck :)

  4. Amiantos
    Member
    Posted 9 years ago #

    I'm browsing my MySQL database under wp_options, looks to me that the first option "siteurl" is "http:" and not my site URL.

    I just tried setting it to the proper url (http://ihavebeenfloated.org) and even though the config panel says it was saved, it was not, it's back at "http:"

    I set it manually by editing the MySQL myself to 'http://ihavebeenfloated.org'

    Refreshed WP, had me re-log in... and checked the MySQL, and the option is back to being 'http:'

    Who wants to bet me twenty bucks that this is the problem?

    Edit: I'm not clear if there is a way to prevent WP from modifying a MySQL option from within PHPMyAdmin, if there is, I would like to test it, could someone tell me if there is? I bet this is the problem, WP is thinking my site URL is wrong and wont let me fix it.

    Jose: Can you go into your options and see what WP is saying your 'Site URL' is? It's on the initial options page.

  5. Amiantos, you have a very bad habit of adding to (editing) your posts while people are writing replies, try writing a new post instead. Then what you want to say will be noticed.

    Jose, here's a tutorial on how to backup your database:
    http://www.tamba2.org.uk/wordpress/backup/

  6. RustIndy
    Member
    Posted 9 years ago #

    That sounds like it might be. I was sitting here trying to think of a way you could safely delete all the records in that table and have them reset to the defaults....

    Of course, now I realize I could just dump the SQL from that test database for you :)

    But if it's being reset each time, that might not do much...

  7. Amiantos, that's been reported before, but not connected to Sending Referrers. I'll look for the report. Welcome to the wonderful world of Nightly Builds.

  8. RustIndy
    Member
    Posted 9 years ago #

    In the wp_options table, set both home and siteurl are identical, and that fileupload_realpath is accurate.

  9. Amiantos
    Member
    Posted 9 years ago #

    Sorry, I figured it was unnecessary waste to keep making new posts, I'll stop that now. Also, I was hoping that would be the problem. ;(

    I'm assuming then that WP doesn't use that option to check that the URL of your referral isn't the URL in the options?

  10. Amiantos
    Member
    Posted 9 years ago #

    siteurl is wrong, at 'http:' but home is correct at 'http://ihavebeenfloated.org' fileupload_realpath is accurate.

    rrr, read the original post wrong. no matter what I set siteurl to, it reverts.

  11. RustIndy
    Member
    Posted 9 years ago #

    and it keeps resetting siteurl to "http:" instead of keeping the real URL?

    make the change again, but query the table afterwards (before going back into WP) to make sure the new value is actually in there...

  12. If it returns to http:, check wp-config.php. If that gives you nothing useful, upgrade to the latest Nightly Build. I believe the http: problem has been fixed.

  13. RustIndy
    Member
    Posted 9 years ago #

    Amiantos, you're using PHPMyAdmin to admin your database, yes? Or something like it? Or are you using a command-line tool or application?

  14. If you're using phpmyadmin, follow this tutorial:
    http://www.tamba2.org.uk/wordpress/site-url/

  15. Amiantos
    Member
    Posted 9 years ago #

    I'm using PHPMyAdmin.

    I just upgraded to the latest nightly, still get the siteurl resetting problem. Even after manually altering the values according to that guide (which I managed to figure out myself earlier, rather proud of myself for that), WP has me re-log in when I load it, and then it resets the value still.

    2005-01-11

  16. jose
    Member
    Posted 9 years ago #

    Amiantos, my home, siteurl and fileupload_realpath is accurate.

  17. RustIndy
    Member
    Posted 9 years ago #

    Amiantos, after you put the proper value in with phpmyadmin, logout of it, then back in, and see if it's still set properly.

  18. Amiantos
    Member
    Posted 9 years ago #

    Well there goes my big hope that I found the problem.

    I did Route 1 a day or so ago. I guess I will try Route 2 tonight when I feel able, going to go eat something and see a movie now.

    Thanks for your help, guys, regardless of what a smart ass I am for no reason at all. WP is still the best there is and I'll probably never leave it, regardless of any problems. If it comes down to it, I'll just overwrite my current theme files so that I can use the new theme when I finish it.

  19. Amiantos
    Member
    Posted 9 years ago #

    In and out of phpmyadmin or out of WP?

    I assume you mean WP.

    Logged out of WP, set value, checked to make sure it suck in the database, relogged in to WP, checked value, it's reset.

  20. RustIndy
    Member
    Posted 9 years ago #

    hmmmmmm.... two more things (both quick and easy to try)

    1) in phpMyAdmin, when you enter your address into siteurl, escape the slash characters with backslashes (http:\/\/mydomain.com) - that might force the issue. can't break it any worse than it is already *shrug* Then try it with two backslashes if it doesn't work - http:\\/\\/mydomain.com

    2) delete or rename the .htaccess file and try to make it work (do the phpmyadmin thing immediately beforehand though, so WP doesn't have a chance to mess with it)

    Jose, the 2nd option above might work for you too.

    And if not, nothing lost but the minute or two it'll take ;)

  21. RustIndy
    Member
    Posted 9 years ago #

    no, i meant log in and out of phpmyadmin - check it there before blaming WP for it ;)

  22. Amiantos
    Member
    Posted 9 years ago #

    1) Did this, caused it to break WP, would try redirecting to 'ihavebeenfloated.org' without the http, so it couldn't even let me re-log in, kind of funny. so technically I guess that option stuck, but only because WP couldn't figure out how to let me access it.

    2) HOLY CRAP!!!!!!!!!!!!!!!!!!!!!!!

    THIS WORKED!!!

    RustyIndy, YOU ARE A GOD.

    *head explodes*

  23. Amiantos
    Member
    Posted 9 years ago #

    If you have a paypal account I will send you $10, because you deserve to be paid for that.

  24. RustIndy
    Member
    Posted 9 years ago #

    Spiffy :D

    Your host has "Virtual Directory Support" set to disabled. Normally, this wouldn't be a problem (at least, it isn't supposed to be), but somewhere in the chain it does occasionally goof things up.

    I have no idea why it would be rewriting what you enter into the database though.... that's a little weird even by my experience.

    Glad it worked for you :) Hope it works for Jose too, and I do have a paypal account, but I ain't telling you what it is ;) But thanks anyways :D

  25. Mark (podz)
    Support Maven
    Posted 9 years ago #

    RustyIndy - wow, complete star !

  26. RustIndy
    Member
    Posted 9 years ago #

    It was last-ditch, y'know ;) My next recommendation was going to be finding a new host :) I don't deal with Linux much these days (too many clients using Winblows), but I have read stuff about htaccess messing with things in weird ways under certain configurations. Figured it certainly wouldn't hurt to try bypassing it :)

  27. RustIndy, ::thumbs up:: great work!

  28. jose
    Member
    Posted 9 years ago #

    mmm... i not have any .htaccess in /html or /html/wpress. My only .htaccess is in the directory /stats...

  29. RustIndy
    Member
    Posted 9 years ago #

    macmanx: thanks :) mostly luck though, i was really dredging the ram here to come up with that.

    jose: i recommend a new host

  30. RustIndy
    Member
    Posted 9 years ago #

    just kidding :) sort of....

    Try that other thing i suggested earlier - backup your wordpress folder, then delete the /wp-include and /wp-admin folders, delete the wp-settings.php file, then re-upload them from the original WordPress file. Let us know if it works

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.