WordPress.org

Ready to get started?Download WordPress

Forums

Enabling Sending Referrers. (86 posts)

  1. sixpackrecoil
    Member
    Posted 9 years ago #

    Wow, this makes me mad. I just tried in 3 web browsers with the instructions given on the codex page. We need to find an alternative to sending referrers, this is obviously bullshit.

  2. Amiantos
    Member
    Posted 9 years ago #

    I second this, it should be an option we can turn off if we like by being leet and modifying a config file ourselves. Both of my browsers are set to send referrers and regardless of what I do it flipflops on deciding to work or not work. Very, very lame. ;( I can't even switch themes to test out my new design.

  3. webwiz
    Member
    Posted 9 years ago #

    Well, I just had the same problem. But, by guesswork, checked my firewall settings and managed to fix it.

    For what it's worth, I have Zone Alarm Pro installed. Checking the Privacy options, I looked at the site list. The "private header" column caught my eye, so I right-clicked that column against the WP site entry.

    From the context menu that pops up, I chose "Options". On the first tab, "Cookies", I noticed a check mark against the entry for 3rd party cookies: "Remove private header information".

    Unchecking this entry and pressing "Ok" fixed the problem. I can now edit links from both Opera and Firefox.

    Hope this helps (Zone Alarm users, anyway.)

    Regards. David.

  4. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Thank you David - I've posted your information into Codex (It was better than what I had written there :) )

  5. RustIndy
    Member
    Posted 9 years ago #

    It's *extremely* unlikely that some sites requiring headers work while WP doesn't, unless a firewall or router (or privacy setting in the browser) is blocking the header transmission on a per-domain basis.

    To see if headers are making it to your domain at all, create a file named info.php containing the following lines:
    <a href="info.php">click me</a>
    <?php
    phpinfo();
    ?>

    Upload the file and open it in a browser. Click the link at the top. When the page refreshes, scroll down to the <b>HTTP Headers Information</b> section (about 1/3 of the way down). The field called "Referer" should contain your domain name and the full path to the "info.php" file you just created (like "http://www.mydomain.com/info.php" or similar).

    If it does, then referrers are not being blocked, and it is a bug. If the field is empty or contains anything but the exact path to your "info.php" file, then it is something else - most likely a router/firewall or privacy setting.

    The important thing is to *click the link first* before checking the referrer setting - it'll be blank (or non-existant) since you will have typed the address in manually. So click first, check after ;)

  6. Please, contribute to this if you'd like:
    http://codex.wordpress.org/Enable_Sending_Referrers

  7. Amiantos
    Member
    Posted 9 years ago #

    Hopefully this'll be enough proof for everyone then that this isn't a silly end user problem:

    http://ihavebeenfloated.org/info.php

    As can be seen there, referrers can easily be seen by my server. Unfortunately, for me, WP still is giving me the same error. I will paste the error text here as "proof" that I am still actually getting the error, even though I could probably type it from memory at this point: "Sorry, you need to enable sending referrers, for this feature to work."

    Thank you RustIndy for providing me with a better way to test my theory that this is a problem with WordPress and *not* myself. If required, I will even take a screenshot with my info.php right next to my WP install giving me an error.

    So much for it being a "server configuration error" or "a problem with your firewall" ad nauseum. (Would it be too much for me to have a smug smirk on my face at this point? *looks around the room* No? OK, then I will go ahead.)

  8. jose
    Member
    Posted 9 years ago #

    Thanks for your info, RustIndy !
    Run the info.php and i have this two references to the referer:
    In 'Session':
    session.referer_check : no value

    In 'Environment':
    HTTP_REFERER: http://www.cromosfera.com/info.php

    Thanks and saludos.

  9. RustIndy
    Member
    Posted 9 years ago #

    Jose, were you having this problem as well?

  10. Amiantos
    Member
    Posted 9 years ago #

    Jose mentioned he was having the same problem here:

    http://wordpress.org/support/topic.php?id=20408

  11. jose
    Member
    Posted 9 years ago #

    Yes, i have the famous problem "Sorry, you need to enable sending referrers, for this feature to work." when i try to activate a plugin, delete a link, delete a user, delete a category, etc...
    thanks,

  12. RustIndy
    Member
    Posted 9 years ago #

    Well, if either of you wants to email me your password and step-by-step instructions on how to trigger the problem, I'll be happy to do the double-check for you.

    russ@innereyesTAKETHISOUT.com

  13. Amiantos
    Member
    Posted 9 years ago #

    I'm not sure if that's the most secure idea, so I'll pass on that unless a developer contacts me specifically.

    As it is, as I stated in another thread, I had a good friend of mine (of five years) who lives across the United States from me try, and he encountered the same problem. Also, I tried on multiple computers at my work (various vanilla installs of Win2k, Win98, WinXP with IE) and had the same problem each time.

    Perhaps if I made a new user account for you, but I would assume that is possibly blocked by the security as well so I wont even bother, I think.

  14. RustIndy
    Member
    Posted 9 years ago #

    Ah k, didn't know that had already been done.

    What versions of MySQL and WordPress are you using?

  15. Amiantos
    Member
    Posted 9 years ago #

    MySQL: 4.0.20

    WP: 1.5-beta-1 2005-01-06

    I was going in maybe install the 2005-01-10 nightly and see if that fixes it but I really doubt it will, though I may at this point anyway.

    BTW: Unlike someone's problem above that only activated upon installing a newer build, my problem occured out of thin air, for no obvious reason, no apparent cause attached. One minute it was working just fine, next minute it just suddenly decided to stop working and hasn't worked sense. Strangest thing ever, makes no sense to me.

    (Also, why in the hell have no stores in my area gotten The Minish Cap in yet? Damnit.)

  16. NuclearMoose
    Member
    Posted 9 years ago #

  17. Amiantos
    Member
    Posted 9 years ago #

    Does NuclearMoose even read the threads he's posting that damn link in? If I see that link again I'm going to gouge my eyes out of my head.

    NuclearMoose: I think we've determined at this point that it is not a firewall problem, but thanks for saying it over and over again.

    (Do I sense some denial here? "Maybe if we just ignore it, it will go away.") I will guarantee the devs that if they release 1.5 and this problem isn't given more thought then "obviously an end user problem", this is probably going to be a lot more wide spread and you guys are going to have a big headache on your hands when the masses get their hands on 1.5 and half of them come flooding into these forums telling you that, yes, they've checked their firewalls eight thousand times and they're pretty sure it's not that.

  18. RustIndy
    Member
    Posted 9 years ago #

    Because 99 times out of 100, that's what it is - a firewall issue.

    The suggestion, of course, is that because the demo site you tried works and yours doesn't (now), it's something specific to your machine. On the other hand, you've had others login to the system who get the same error, which suggests a server-side issue (or a bug).

    This started just few days ago for you? A week ago? Two?

  19. Amiantos
    Member
    Posted 9 years ago #

    A few days ago, the eighth, I believe. Like I said before, it was working, then it suddenly wasn't. As far as I am aware of, no changes were made to the configuration of the server and no changes were made by me to the WP install between the instances of WP working properly and WP not working properly. I can always email my host and ask them if there were any changes made to my machine between the seventh and the eighth, just to check.

    (I'm hosted by 1&1 and use their Premier Professional package, so the likelyhood that it is some strange glitch in their systems seems very unlikely to me, but who knows.)

  20. jose
    Member
    Posted 9 years ago #

    Mysql 3.23.54
    WP 1.2.2
    I have installed WordPress aprox. five days ago. For me all this time is impossible to delete a link, or message, or activate a plugin, etc. in my installation.

  21. Amiantos
    Member
    Posted 9 years ago #

    Oh, that's weird, I figured this problem was 1.5 specific.

    What company are you hosted by jose?

    Can you do me another favor jose, and list what plugins you have Activated in your plugin list?

    (Mine: Adhesive, dtw_get_links_list, Get Custom Field Values, Spam Karma, StatTraq, Textile 1, Witty Text, WP Gallery, WP Plugin Manager)

  22. RustIndy
    Member
    Posted 9 years ago #

    Hokay you two, head to http://test.innereyes.com and try and duplicate the problem. Login is "admin", password is "wptest". Let me know how it goes :)

    Amiantos, if you can, disable all your plugins temporarily and see if the problem still occurs (i assume you've probably done this already, but best to be certain).

  23. Jose and Amiantos, you can both temporarily disable your plugins by renaming the plugin files via FTP. Give that a shot.

  24. RustIndy
    Member
    Posted 9 years ago #

    Jose hasn't been able to activate any plugins at all, so none are running on his installation. Last time I checked, though, StatTraq didn't get along with WP1.5, which is why I suggested Amiantos disable all his - just in case ;)

  25. jose
    Member
    Posted 9 years ago #

    for RustIndy:
    It works in your site-test ! I have deleted links and activate plugins without problem.

    for Amiantos and macmanx:
    my ISP is Arsys http://www.arsys.es
    and i have the original installation, i'm unable to activate any plugin.

  26. Amiantos
    Member
    Posted 9 years ago #

    the wptest works for me.

    Removed all of my plugins from my WP install, still doesn't work. ;( I was hoping stupidity on my part would be the problem, but no dice. Great way to clean up your plugin dir, I can just put back what I need... course now my site will be broken due to inactivated plugins not being able to be activated again.

    Crap, that was a bad idea. ;(

    Oh, phew, they were automatically reactivated, nice. Yay!

    (And I left StatTraq removed, but FYI, I never had any problems with it really aside from a blank referral showing up in the logs a lot for some reason.)

  27. Jose, do you have any way of reaching another computer or someone else's? It would be best if this was a different operating system from what you're using (Windows vs. Mac OS X), this will mostly distinguish whether or not the problem is server-based. If you can't get to a different computer with a different OS, then try a different browser (IE vs Firefox). Once you get your hands on one of the above, try to login on that computer and/or browser and attempt to activate plugins.

  28. Amiantos, the plugins should not reactivate, that's probably part of the problem. If you really want to test without plugins, you'll have to rename them via FTP. Of course, if that doesn't work, you won't be able to activate your plugins. Were you able to recreate the problem on RustIndy's test site yet? He has a valid point that StatTraq may be interfering. There are a few threads that discuss changes that need to be made to StatTraq in order for it to run properly under WP v1.5. So, it's logical to assume that it doesn't run properly under v1.5 and may be causing your problems.

  29. Amiantos
    Member
    Posted 9 years ago #

    Well, like I said, I removed StatTraq, so it's gone now.

    And no, I can't recreate the problem on RustyIndy's test site, it works just fine for me. I can play around with it some more.

    I deleted all the plugins from the directory, is renaming them some how different? When I re-uploaded them, they were all set as activated in the configuration, which I assumed is how it should work.

  30. Amiantos
    Member
    Posted 9 years ago #

    Also: I just upgraded from 2005-01-06 nightly to the 2005-01-10 nightly and the problem persists. Was hoping that would fix it some how.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.