WordPress.org

Ready to get started?Download WordPress

Forums

nrelate Related Content
Enabling nrelate on is_single breaks jQuery? (5 posts)

  1. Steven Lambert
    Member
    Posted 11 months ago #

    I just installed the plugin and was setting it up when I noticed that SyntaxHighlighter plugin was not loading. I looked into the console logs and it seems that my the scripts at the bottom of my page (SyntaxHighlighter, Disqus, and a few others) are loading without jQuery or Underscore being defined yet. This doesn't happen when there are no pages that are selected to display related content in the "Layout Settings," but only seems to occur when the option is set to display in is_single.

    I'm not sure exactly what the problem is, but the plugin itself seems to be working fine. I'm curious why it seems that it interferes with my normal loading of other scripts and/or jQuery itself. My site is http://blog.sklambert.com/. I've disabled the option for now so that SyntaxHighlighter will load properly.

    http://wordpress.org/plugins/nrelate-related-content/

  2. katrina@nrelate
    nrelate Support Rep
    Posted 11 months ago #

    @Steven Lambert -- Thanks for using nRelate on your site. We're looking into this issue regarding jQuery and I'll let you know what we find.

    - Katrina @ nRelate

  3. katrina@nrelate
    nrelate Support Rep
    Posted 11 months ago #

    @Steven Lambert -- We weren't able to reproduce this issue on our test sites, and we'll need to see the plugin active in order to trouble shoot. Would you like to meet with us over Webex (screen sharing like skype) so we can see what might be going on for a fix? Let me know and we can schedule something at your earliest convenience.

    - Katrina @ nRelate

  4. Steven Lambert
    Member
    Posted 11 months ago #

    I could duplicate my WordPress site onto a staging environment. That way, you can have complete access to the plugin and it's settings and I can keep my site up without messing with it directly.

  5. katrina@nrelate
    nrelate Support Rep
    Posted 11 months ago #

    @Steven Lambert -- If it's no trouble, then that would be great. Please do so and let us know so we can take another look.

    - Katrina @ nRelate

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.