WordPress.org

Ready to get started?Download WordPress

Forums

Enabling Comments (7 posts)

  1. Vulturo
    Member
    Posted 9 years ago #

    Hi, I've just got WordPress Set Up on my blog. The problem is, no one can comment on my blog

    I did search the forum on the issue, but couldnt come across a 'resolved' problem

    I have enabled "anyone can register" and unchecked users must be logged in to comment. My blog address is http://weblog.vulturo.com

    Would appreciate help on this.

    Saket

  2. carthik
    Member
    Posted 9 years ago #

    Clicking on comments does not lead to the comment form. Check if you have the comments-post.php and/or comments.php files (the files in your theme for the comments) in the wp-content/themes/default/ directory.

    Also you need to "enable comments" for all posts in the admin panel.

  3. Vulturo
    Member
    Posted 9 years ago #

    The wp-content/themes/default contains "comments.php" and "comments-popup.php", also the main blog directory contains "wp-comments.php", "wp-comments-post.php", "wp-comments-popup.php", "wp-comments-reply.php" and "wp-commentsrss2.php"

    Can you tell me where exactly to enable comments on all posts in the Admin Panel

  4. banzona
    Member
    Posted 9 years ago #

    I am having the same problem. What was the fix for this?

  5. grendelquinn
    Member
    Posted 9 years ago #

    I have the same issue, I think. No matter which theme I try - edited or not, when I click on comments my page just reloads the index.php file (whether I try with pop up or without). I've tried various fixes found in the forums, even those for issues around setting up permalinks and for upgrading 1.2 to 1.5. I've now removed everything and freshly installed WP 1.5 at http://grendelsweb.com/journal to try to start fresh (but still unable to view or add comments.

    I've toggled on and off the various moderator and comment access settings without luck.

    Can you let me know how you fixed your site? Thanks for any help, Beth

  6. brainspout
    Member
    Posted 9 years ago #

    I've got the same problem, this is obviously some sort of bug. I was shocked that the 5 minute installation actually took 5 minutes - too good to be true I suppose...

    Vulturo appears to have figured it out as his comments are now working, hopefully he will return and share the wealth or perhaps carthik will be able to help.

  7. grendelquinn
    Member
    Posted 9 years ago #

    The answer given by Kafkaesqui in the following post worked beautifully!
    http://wordpress.org/support/topic.php?id=27216

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.