WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
Enabling CDN Support not rewriting url correctly (7 posts)

  1. tabeytabe
    Member
    Posted 2 years ago #

    I have all of my files uploaded to Amazon S3 and am using Cloudfront. When I disable caching, clear cache and enable CDN Support it is not rewriting the urls correctly. For example my browser will try to grab the url: http://gizmoninja.com/ds07r0kq9irtk.cloudfront.net/wp-content/uploads/2011/04/hot-deals-150x100.jpg instead of http://ds07r0kq9irtk.cloudfront.net/wp-content/uploads/2011/04/hot-deals-150x100.jpg
    As you see, it's putting my regular domain url and THEN the cdn url.. instead of replacing the domain url.
    I have no idea where to look to get this working properly. Any thoughts?

  2. tabeytabe
    Member
    Posted 2 years ago #

    Is this support forum not active? Or just nobody is able to assist with my particular issue?

  3. Donncha O Caoimh
    Member
    Plugin Author

    Posted 2 years ago #

    Did you include "http://" in the CDN url(s) on the settings page?

  4. tabeytabe
    Member
    Posted 2 years ago #

    Thanks for the response Donncha. Right now I'm not populating the CNAMES field, as I thought that is optional? I was trying to get it to work with just the offsite URL configured (my url from Cloudfront, without the "http://"). Is configuring the CNAMES mandatory?

  5. Donncha O Caoimh
    Member
    Plugin Author

    Posted 2 years ago #

    No, you need to give it the url of your Cloudfront CDN, with http://.

  6. tabeytabe
    Member
    Posted 2 years ago #

    Ah, ok! I'll give that a try tonight and report back. Thanks!

  7. tabeytabe
    Member
    Posted 2 years ago #

    That was it! Thanks a lot Donncha!

    Now I need to figure out why enabling CDN for wp-content causes slidedeck to mess up and my Dashboard menu to mess up with wp-includes! Oh, and also when new images are posted with posts the images upload to Amazon as 0bytes... so no image there, just the filename. :/

    Thanks again Donncha!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic