WordPress.org

Ready to get started?Download WordPress

Forums

Enabled theme not being used... (3 posts)

  1. LJagermaster
    Member
    Posted 3 years ago #

    Apologies if this has been asked before but after several searches I've not found anything on it.

    I've just created a "sub-blog" under my main site at http://sin.theweare.net (using the MS network features), the new blog is http://sin.theweare.net/ljagermaster.

    If you view both of them you'll see that the new "sub-blog" is using the now default twenty twenty theme. Trouble is under the Super Admin menu of my main site I set the "Network Themes" settings to disable the twenty twenty theme and enable my custom theme - which in theory should force all new blogs to use the custom theme - and yet the default theme is still being used for new blogs.

    The idea behind what I'm trying to achieve is to provide members with their own "hub" to share their views on the specific theme of the main site (it's for a monthly club gig run/DJ'd by one of my friends), so ideally they'd only be able to submit posts and add pages for things that interest them.

    Is there a way to make sure that only a specific theme (in this case my custom one) is used for every new blog created via the main site?

    I'd prefer to do this without hacking core files since wordpress eradicates all changes on each update, however if that's the only way then I'd still like to know as the extra work in re-hacking files would be worth it to keep the theme (and all plugins/widgets activated on the main site) fluent throughout the entire network of sites...

    Thanks in advance,

    LJ

  2. I set the "Network Themes" settings to disable the twenty twenty theme and enable my custom theme - which in theory should force all new blogs to use the custom theme

    No, that's not what that setting does. Enabling a theme just means it is accesible via the Appearance menu. Disabling a theme means users cannot select it.

    To set the default theme without using the "new blog defaults" plugin (which has many other settings you may or may not need) just do this:

    define(‘WP_DEFAULT_THEME’, ‘theme-folder-name’);

    in your wp-config.php file.

    no hacking needed.

  3. LJagermaster
    Member
    Posted 3 years ago #

    Thanks for the reply Andrea, and the plugin tip. Just configured the settings for it but won't have time to test it properly til tomorrow. Hopefully it'll do what I need, if not I'll try the hard-code method (can't believe I forgot about the config file, d'oh!).

    Thanks again,

    LJ

Topic Closed

This topic has been closed to new replies.

About this Topic