WordPress.org

Ready to get started?Download WordPress

Forums

Enabled MultiSite, but "Network" option doesn't show up. (21 posts)

  1. Pat Friedl
    Member
    Posted 3 years ago #

    Hi all. I've don through all the instructions on enabling WordPress Network, and I've added this line: define('WP_ALLOW_MULTISITE', true); to the wp-config.php file.

    However, I can't get the network settings to show up. Any ideas?

  2. Where did you add the line? Is it above the 'stop edting here' marker?

  3. make sure you have straight up and down quotes : ' and not curly ones which show up in Windows.

  4. Pat Friedl
    Member
    Posted 3 years ago #

    Yup, checked all that and I did add before the "happy blogging!" line. Is there any way to debug this? I've never done a network setup before.

  5. Do you have define('WP_DEBUG', false); in your wp-config?

    If so, put the define('WP_ALLOW_MULTISITE', true); call right below that.

  6. Pat Friedl
    Member
    Posted 3 years ago #

    Yup, that's exactly where it is.

  7. paste us in the few lines of code around that chunk. (not the whole config file and for heaven's sake not any passwords)

  8. Pat Friedl
    Member
    Posted 3 years ago #

    Here ya go:

    [snip]
    define ('WPLANG', '');
    
    /**
     * For developers: WordPress debugging mode.
     *
     * Change this to true to enable the display of notices during development.
     * It is strongly recommended that plugin and theme developers use WP_DEBUG
     * in their development environments.
     */
    define('WP_DEBUG', false);
    define('WP_ALLOW_MULTISITE', true);
    
    /* That's all, stop editing! Happy blogging. */
    
    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    [/snip]

    Now, I did notice that there's a lot of posts where dreamhost users were having issues with network installs, but they're old. This site is on DreamHost - that shouldn't be an issue right?

  9. It could be dreamhost... are you on shared hosting?

  10. This site is on DreamHost - that shouldn't be an issue right?

    Yes. That IS the issue. Go double check with their support team that they will allow you to enable multisite on that level of account.

    Because at one point they were crippling installs that tried to.

  11. Pat Friedl
    Member
    Posted 3 years ago #

    Yes, it's shared hosting, but apparently they support it now if you're using the subdirectory install. I can't imagine having the static IP would make network settings show up though, right?

  12. Pat Friedl
    Member
    Posted 3 years ago #

    Thanks Andrea - looks like I'll be calling support! I REALLY need to finish getting my own hosting going on Amazon's EC2 ...

  13. I can't imagine having the static IP would make network settings show up though, right?

    f they coded a check in there somewhere, then yes. it's entirely possible.

  14. silentlikefish
    Member
    Posted 3 years ago #

    Same issue - and I'm on EC2. I run several sites, including network sites.

    It seems like enabling network is a 50/50 bet. Sometimes it works elegantly, others not so much due to this issue where it doesn't show up as an option.

    Right now I'm pulling my hair out because it simply won't show even though it's in the file:

    define('WP_DEBUG', false);
    
    define('WP_ALLOW_MULTISITE', true);
    
    /* That's all, stop editing! Happy blogging. */

    Please tell me I have a typo above?

    Restarting apache and all other little tricks (cache clearing, different browsers, etc) -- nothing working. I really need to get multi-site running. GRRRRR.

  15. Pat Friedl
    Member
    Posted 3 years ago #

    SilentLikeFish - on a side note, I'd be very interested in seeing how you have yourself set up on EC2 - I've been wanting to migrate that direction myself!

  16. @silentlikefish stick it higher up in the file

  17. silentlikefish
    Member
    Posted 3 years ago #

    I've moved it everywhere. A few lines up, mid-way up, and it's top of the file at the moment. No dice.

    A few other things I've tried to no avail:

    - killed Super Cache. Didn't help - re-enabled it.
    - set debug true and didn't see any change? Is WP admin listening to wp-conf.php?
    - validated it's not working by pulling /network/admin.php. Love the message that it's not working. Really? ;-) What did I expect...

    Each change, I'm also rolling the httpd process... just for the fun of it. up, down, up, down

    If I can find the pattern to fix this I swear I will write it down someday... this is not the first time I've searched the forum here. Last time - I wiped the server. Reinstalled EVERYTHING, put the line in the conf file and it worked like a charm. Not an option this time.... ;-(

  18. silentlikefish
    Member
    Posted 3 years ago #

    @kcfried - Happy to detail EC2 setup via pm or email. We've been on Amazon for years. Love it. We use GoDaddy, Rackspace and others too - so happy to chat pros and cons for WP

  19. silentlikefish
    Member
    Posted 3 years ago #

    FIXED.

    My dev environment:
    - MAC OS X 10.6.8
    - Filezilla FTP 3.5.0
    - TextWrangler Editor 3.1 Build 2640

    Server: Fedora 8 32bit EC2 AMI on Amazon Cloud
    Elastic IP: yes

    Issue:
    I was editing the file, confirming the edit, re-uploading the file (even manually replacing it) and the "Network Setup" option simply would not show. Moving the line up and down in the wp-config.php file didn't help either.

    I keyed on the fact (mentioned in my post earlier) that setting debug "on" in the wp-config.php file wasn't working either - so it wasn't just the WP_ALLOW_MULTISITE statement. I know about the treads on the WP forum that point to editors inserting characters that cause problems... so I was being careful of that all morning, ensuring that each time I edited the file with my friendly GUI editor the time stamps changed and 'cat'ing the file from the Linux prompt to ensure it looked good -- But still somehow my edits were not getting picked up by WP.

    Solution:

    I used ssh to get to the shell/command line of my web server, hand edited the wp-config.php file using VI and found that even TextWrangler has inserted all kinds of crap into my code. Specifically inserted were "^M" or carriage returns. UGH.

    I edited the file using VI to remove the extra returns, etc -- and "Network Settings" popped up in the "Tools" section of WordPress right away.

    --

    Should have known to use "vi" editor ... I'm old enough. If you're not familiar with it - it can be daunting, but it's included with Unix/Linux in almost all cases and won't add extra codes to your files as you edit. It requires ssh/shell access to your web server, which you may have to specifically request from your hosting facility, and may not be able to get on a shared server. That said, here's a vi reference for the brave:

    http://adminschoice.com/vi-editor-quick-reference

  20. TextWrangler doesn't do that for me, but BUT but. If you saved the file as a Windows file and not unix, it could easily do that.

  21. plain text editors FTW. ;)

    And for adding the multisite defines, I just edit the file on the server.

Topic Closed

This topic has been closed to new replies.

About this Topic