WordPress.org

Ready to get started?Download WordPress

Forums

Enable Sending Referrers my ass (13 posts)

  1. greypilgrim
    Member
    Posted 8 years ago #

    Having just lost a post I spent an hour working on, I am a little p.o.ed. So excuse the heat. I've been having a problem where when I click "save" or "publish," I get a page with a one line message telling me I need to enable sending referrers for "this feature" (whatever that is) to work. When I hit the back button, my post is gone and WordPress did not save it.

    After losing more than one post this way, I started copying my post to a text document before clicking save. Needless to say, I didn't do that this morning, and I lost a post I spent an hour writing.

    I realize there are instructions in the documentation for enabling sending referrers, and I tried those for both Firefox and IE. They didn't work!

    I have never had this problem until after upgrading to 2.02. Why is WordPress doing this?

  2. Chris_K
    Member
    Posted 8 years ago #

    The exact error would be useful -- often the first part is the real error ,and because of that error, you get the sending referrers thing.

    For instance, do any of your plugins have extra whitespace at the very top or very bottom of them?

  3. greypilgrim
    Member
    Posted 8 years ago #

    The exact error is "You must enable sending referrers for this feature to work." There is a link to the page in the Support documentation on enabling sending referrers. I have done what that page suggests, but it has not worked.

    Sometimes I can post with no problem, sometimes I can't. Strangely, when I'm using my computer at work, behind a firewall, I don't have this problem. It's only recently cropped up, and it's only on my home computers. Do I need to log out of WordPress after every use?

  4. Mark (podz)
    Support Maven
    Posted 8 years ago #

    You could try this?
    http://www.thecodecave.com/?p=106

  5. greypilgrim
    Member
    Posted 8 years ago #

    I'll give it a try. Thanks for the link. Is there a reason why this problem is occurring? Is it because I use too many different computers to do my blogging?

  6. mike
    Member
    Posted 8 years ago #

    I had some luck messing with Norton's privacy settings as mentioned in the Codex.

    I have installed over a dozen blogs for people and for each one this problem has come up at least once. It usually happens after I upgrade their software. The problem normally goes away with cookie deletion or just a little patience. It happened to one of my blogs the first time yesterday and the former cookie approach fixed it.

    Nonetheless, I think this is a significant issue that needs to be resolved in further releases.

  7. monkeypup
    Member
    Posted 8 years ago #

    This happened to me and it killed me! For the longest time. I tried every damn thing I could find in the codex and on google to fix it, and nothing worked. Then, based on a suggestion (from Lorelle, I think), I checked the wp-admin options page and found that my site was listed as www dot sitename dot com rather than sitename dot com (notice the lack of www), which is what I always browsed to. I removed the www, saved it and boom! All was well. If you can't change it there, you can do it in your mysql database.

    May not work for you, but it worked for me!

  8. davidchait
    Member
    Posted 8 years ago #

    monkeypup - add that to the faq on this on the codex... ;)

  9. monkeypup
    Member
    Posted 8 years ago #

    I just might do that, you plugin-master, you.

  10. MichaelH
    Member
    Posted 8 years ago #

    I've added to the Codex, this:
    FAQ about Sending Referrer message

    But monkeypup, did you change both the WordPress address (URI) and the Blog address (URI)?

    Oops, link not working but it's here:
    http://codex.wordpress.org/FAQ_Troubleshooting

    under this question--

    Why do I get an error message about Sending Referrers?

  11. monkeypup
    Member
    Posted 8 years ago #

    Michael,
    I did. I made sure they matched, and I also made sure to change my browser shortcuts to match.

  12. MichaelH
    Member
    Posted 8 years ago #

  13. klklaser
    Member
    Posted 7 years ago #

    I edited edit-form-advanced.php (v.1.5.2) to include a small reminder (as text) right before the "save and continue editing" button. Maybe that will help without affecting security.

Topic Closed

This topic has been closed to new replies.

About this Topic