WordPress.org

Ready to get started?Download WordPress

Forums

enable sending referers? (16 posts)

  1. kmurphy
    Member
    Posted 9 years ago #

    This is a second post... my apologies... to the string dealing with the "Sorry, you need to enable sending referrers, for this feature to work." But I can't seem to get any of the solutions mentioned to work.
    I tried the editing of function check_admin_referer() as mentioned in http://wordpress.org/support/3/5937 but it did not work for me. I am using Firefox as a browser but tried in IE as well, still didn't work. I am also runing Norton Anti Virus so disabled it to see if that was conflicting in anyway, but it still didn't work (I know an IT Security person who tells me to dump Norton because it is such a pain and is usually the root of all the networking problems she deals with).
    All that said, the problem could still be in my set up: I am running WordPress on my default installation of Apache on my home computer.
    My ISP here in BC, Telus, has started to block port 80 to stop people from running web servers from their standard accounts at home... have to give them a whole lot more $$ to get a static IP and open port 80.
    However, I set my router (standard Linksys Etherfast cable/dsl 4 port) and configured Apache to listen to port 9090 for the http server. I also use http://www.no-ip.com and their Dynamic Update Client to automatically update the dynamic IP # assigned by Telus.
    It all works fine, and I do this so that I can build and test web sites on my home computer. Now I say it all works fine, or has, at anyrate, until this 'referer' problem. I can't seem to find a fix that works, and that may be simply because of the wacky rerouting going on explained above. Though I am not sure, and I suppose will not be sure until I post all of this up on a server and get the proper URL without having to reroute to different ports etc.
    BUT if anyone has any other thoughts as to what may be going on, I would love to try and work them out as I really want to be able to run WordPress off my server at home as well...
    I have WordPress installed here http://murphyzone.no-ip.com/GCCBFM/news/blog/
    (again, this is on my old laptop so performance may not be the greatest...)
    thanks

  2. kmurphy
    Member
    Posted 9 years ago #

    thought I should add that I have removed all of my add blocking software as well... still no go....

  3. Matt Mullenweg
    Troublemaker
    Posted 9 years ago #

    When I browse to the link you gave it takes me to
    http://154.20.114.114:9090/GCCBFM/news/blog/
    If that's what is in your address bar that's what the browser will send as the referrer, and it needs to match your site url in your options.
    Alternatively, you can just delete everything inside of
    function check_admin_referer() { ... }

  4. kmurphy
    Member
    Posted 9 years ago #

    ahhh that did it thanks!
    So this issue was just another ID-10-T error on my part...
    by rerouting my ip via the port 80 redirect option at http://www.no-ip.com I am unable to use the DNS alias so after doing so I noticed that whenever the page is loaded, that the real ip address is posted rather than the alias, in my case 'murphyzone.com'...
    Thanks again.

  5. malinusmaximus
    Member
    Posted 9 years ago #

    question what file is the function check_admin_referer() { ... } located in so i can edit it?
    That referrer id seems to be a huge problem. I installed directly from cpanel and i chaneged all the suggested in fo that was in earlier posts and no help.

  6. leslie0629
    Member
    Posted 9 years ago #

    Disable Norton Internet Security.

  7. vkaryl
    Member
    Posted 9 years ago #

    He said he had NAV, and disabled it already - didn't mention NIS.

  8. sarah07
    Member
    Posted 9 years ago #

    i deleted the headers in the wp-admin/index.php file and i never got those anymore!! hahaha!!

    the one that said header ('Last Modified..
    those four ones i believe.. i actually deleted it coz of the pluger thingie.. then i don't know.. it worked.. i hit 2 birds with one stone i guess..

  9. insensible_mistress
    Member
    Posted 9 years ago #

    Forgive me if I'm blind, but I'm not able to find where to edit the function check_admin_referer(). Please help... that thing is driving me crazy. Thanks!

  10. insensible_mistress
    Member
    Posted 9 years ago #

    Sorry, you need to enable sending referrers, for this feature to work.

    I ask for help... then find it. Thanks anyway!

  11. Mark (podz)
    Support Maven
    Posted 9 years ago #

    # /wp-admin/admin-functions.php -> line 468

    Should be around there ..

  12. insensible_mistress
    Member
    Posted 9 years ago #

    You are my new hero!! lol Thank you so much. I was getting so frustrated!

  13. tsbalaban
    Member
    Posted 8 years ago #

    I'm confused. HTTP_REFERER from my post.php is blank. How do I enable referers? Is it in WordPress, my browser or in my server PHP php.ini?
    Do I change check_sdmin_referer() ?

  14. tsbalaban
    Member
    Posted 8 years ago #

    I found a post on codex: you have to set your site as a trusted site in the browser and your firewall.

  15. ashish1
    Member
    Posted 8 years ago #

    The WP is a total mess.I disables all firewall(including XP inbuilt) ,Mcaffeee ,Edit every thing that was told in

    http://codex.wordpress.org/Enable_Sending_Referrers
    (Why this is told every time someone ask this question,I think this is complety useless as this does not work for over 300 machines my users used)

    The only solution was to edit function check_admin_referer
    Not sure if this will lead to other problems.

    I have 1 solution through buy another Blogging script.

  16. alnames
    Member
    Posted 8 years ago #

    Here's my fix, for what it's worth. I understand enabling sending referrers means that the user is sending the web page he/she is coming from to the web page he/she is going to for security purposes. I am using a dynamic dns service to forward requests for my site at "www.mysite.com" to "ww2.mysite.com:8000" (because my ISP blocks port 80) located on a server in my home. By leaving the "blog Address" to "www.mysite.com" and changing the "WordPress address" to "ww2.mysite.com:8000", I could now make changes through "ww2.mysite.com:8000/mysite/wp-admin" without to dreaded "enable sending referrers" problem. The original problem may have been a combination of the dns redirect and the cloking of the redirected address.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.