WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Enable Referers Fix when changing directories (1 post)

  1. DylanHunter
    Member
    Posted 8 years ago #

    If you're trying to move the directory of your blog as part of your upgrade, (i.e. from http://www. mywebsite .com/blog - no spaces - to http://www. mywebsite .com - no spaces) you're going to find that you're still in deep doo-doo after you follow the install directions, (i.e. you'll notice there's no theme at all on your blog now, just the raw text, and if you open up your error logs, you'll see that it's still trying to access mywebsite .com/blog/... rather than mywebsite .com/...).

    If you can get through to your admin logon, you'll see that it also keeps popping /blog/ as part of the URL, and if you try to modify it directly in the address bar, you'll get the "enable referers" thing again and again. You'll read the docs, make sure all the settings are correct, (they will be). You'll clear all your cookies, etc., still no joy.

    The cause is simple, in the database behind WP, it's still reading that your blog should be at blah.com /blog, and until it finds everything there, thanks to the referer thingus, it appears to not let you change it.

    Simple solution, (presuming you have access to phpMyAdmin through your webhost). And warning - you're inside your WP database, so if you're not comfortable mucking around in your db, either get a friend to help, or only do the following, (it's actually pretty safe, just don't futz with anything else! :) ). Access phpMyAdmin for your database, click on the wp_options table in the left pane, and then click "browse." The first item you'll see is "siteurl," which is still set to the old path. Click on the pencil, ("Edit") remove the /blog from the option_value box, (can also remove from the option_description if you want - not necessary, but what the heck).

    At the bottom of the page, you should see two option boxes separated by the words "and then." They should be set to "Save" and "Go back to previous page," respectively, (if not, set them to these values). Click on the Go button, and reload your blog, which you now should see in the default theme, (big blue box in the middle). Then close out the window you were in phpMyAdmin with, stop cursing, and enjoy your new WP 2.0 blog! :)

Topic Closed

This topic has been closed to new replies.

About this Topic