WordPress.org

Ready to get started?Download WordPress

Forums

Events Manager
[resolved] Enable comments (7 posts)

  1. jpvanmuijen
    Member
    Posted 3 months ago #

    Hi,

    I found a lot of topics around disabling comments on events, but I actually want to switch them on for a specific one.

    So far I've tried:
    - Enable comments via WordPress Settings (works fine for regular posts)
    - Enable comments via Events > Settings > Pages > Events
    - Enable comments on the specific event
    - Switch page template
    - Disable all of the above and enable again
    - Create a new event

    So I'm pretty much running out of options.
    Any ideas?

    Thanks

    https://wordpress.org/plugins/events-manager/

  2. angelo
    NetWebLogic Support
    Posted 3 months ago #

    sorry for the confusion but you've wanted to do is to disable comments BUT enable it to a specific events? is this correct?

  3. jpvanmuijen
    Member
    Posted 3 months ago #

    Exactly, thanks for your reply.
    Enabled by default and switching them of individually would be fine as well.

  4. philipjohn
    Member
    Posted 3 months ago #

    Okay, so can you get to the point where comments are enabled for all events?

    And from there, can you uncheck the comments enabled option on the event editor page?

    Thanks

  5. jpvanmuijen
    Member
    Posted 3 months ago #


  6. jpvanmuijen
    Member
    Posted 3 months ago #

    As it turns out, this seems to be a theme issue.
    I just switched to the 2014 theme which did show the comment area. Weird thing is, when I use a page template for the event page -which does show comments in other places- it still won't work.
    Anyway, I'll dig around some more in that area.
    Sorry to have bothered you.

  7. jpvanmuijen
    Member
    Posted 3 months ago #

    To clarify a bit more: I used a full width page template, which contained a bit of script which determined to either show or hide comments based on a theme setting per page.
    This setting is missing from the event post type, so it just left it out apparently.
    Bit of a weird lost-in-between situation I guess.

    My solution is to copy this page template and make it show the comment area by default.

    In case anyone is wondering.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.