WordPress.org

Ready to get started?Download WordPress

Forums

Custom Content Type Manager
[resolved] Enable archives (15 posts)

  1. Araminho
    Member
    Posted 1 year ago #

    Hi everyone.
    I'm trying to include custom postes into archive pages like this - site.com/?m=20130326 (day archive) or site.com/?m=2013 (year archive). I have enabled archives for my post type in Edit->Advanced section. But it didn't help. I see only simple posts on my archive pages. Please help, what should I do?
    The plugin I'm using is "Custom content types manager".

    http://wordpress.org/extend/plugins/custom-content-type-manager/

  2. fireproofsocks
    Member
    Plugin Author

    Posted 1 year ago #

    What version of the plugin? There's a screen in the CCTM admin pages that prints out all the info about your site and the the other plugins and pages you're using. That's extremely important info for troubleshooting. It's also possible that your theme is not properly querying for custom post-types.

  3. Araminho
    Member
    Posted 1 year ago #

    Hi. If you mean "Info" page, here is what was written there:
    Plugin Version: 0.9.7-pl
    WordPress Version: 3.5.1
    PHP Version: 5.3.3
    MySQL Version: 5.1.67-log
    Server OS: Linux
    I've tried to deactivate all my plugins except "Custom Content Type Manager", but it didn't help. My theme is "Churchope" and it workes fine with all other functionalities of "Custom Content Type Manager".

  4. fireproofsocks
    Member
    Plugin Author

    Posted 1 year ago #

    Try using one of the default themes and see if that affects any of the behavior. WP is a pain to troubleshoot with this stuff because it's never clear if a plugin or a theme is modifying core functionality. If the problem persists, please file this in the bug-tracker: I am sure to forget about it and all the details otherwise. Thanks.

  5. Araminho
    Member
    Posted 1 year ago #

    Thanks for answering. I have chcanged to 2011 default theme, turned off all other plugins, and the problem remains. You can see it here http://newsite.2halfchefs.ru/wordpress/?m=201303
    The calendar shows several custom posts in March, but the archive page shows only simple posts.

    Please tell me where should I report about this, if it is a bug? I hope it can be solved soon.

  6. fireproofsocks
    Member
    Plugin Author

    Posted 1 year ago #

    Report it in the bug tracker. There is a link at the bottom of every CCTM page in the WP manager. Please copy and paste all the information on that page into your bug report. If you can't find it, please read the info where you downloaded the plugin.

  7. Araminho
    Member
    Posted 1 year ago #

    Thanks for information. Unfortunately I couldn't open an issue, the "Submit issue" button is inactive for, and I have no idea why. I'll copy the full text here. Please be so kind to consider it this way.

    I'm trying to include custom postes into archive pages like this - site.com/?m=20130326 (day archive) or site.com/?m=2013 (year archive). I have enabled archives for my post type in Edit->Advanced section. I have changed my theme to 2011 default, turned off all other plugins, but it didn't help.
    Here is the month archive page http://newsite.2halfchefs.ru/wordpress/?m=201303 . It shows only simple posts, but in fact I have there several custom posts.

    *SYSTEM INFO*
    ------------------------
    Plugin Version: 0.9.7-pl
    WordPress Version: 3.5.1
    PHP Version: 5.3.3
    MySQL Version: 5.1.67-log
    Server OS: Linux
    ------------------------
    ACTIVE PLUGINS:
    * AdRotate v.3.8.4.2 [http://www.adrotateplugin.com]
    * Cackle comments v.3.03 [http://cackle.me]
    * Contact Form Manager v.1.3 [http://xyzscripts.com/wordpress-plugins/contact-form-manager/]
    * Facebook Like Box v.2.4 [http://wordpress.org/extend/plugins/facebook-like-box-widget/]
    * Image Widget v.4.0.7 [http://wordpress.org/extend/plugins/image-widget/]
    * Polylang v.1.0.3 [http://polylang.wordpress.com/]
    * WordPress SEO v.1.4.4 [http://yoast.com/wordpress/seo/#utm_source=wpadmin&utm_medium=plugin&utm_campaign=wpseoplugin]
    * WP Ya.Share v.1.2 [http://andrey.eto-ya.com/wordpress/my-plugins/wp-ya-share]
    ------------------------
    CURRENT THEME: Churchope v.1.11 http://churchope.themoholics.com

  8. Araminho
    Member
    Posted 11 months ago #

    Hello, any news about this bug? I hoped it will solved after plugin update, but it still remains.

  9. fireproofsocks
    Member
    Plugin Author

    Posted 11 months ago #

    I completely forgot about this because it's not int the bug tracker. Sorry, that's really the ONLY thing I ask for: file bugs in the bug tracker, otherwise I don't see them when I sit down to work. If you need something fixed, then you have to hire me -- I only have enough time to focus on the bugs that I've been hired to fix... the others I get to when I can. Sorry if that makes me sound like a prick, but I only have so many hours in the day.

  10. Araminho
    Member
    Posted 11 months ago #

    Thank you for your answer. I already tried to add this in bug tracker, but it doesn't allow me, "submit issue" button is always disabled, I can't understand why.
    Please tell me the terms how I can hire you (my email is araminbox at gmail dot com)

  11. fireproofsocks
    Member
    Plugin Author

    Posted 11 months ago #

    You have to have a valid Google account to log into the bug tracker -- you should qualify as you have a gmail account. Other people have been filing bugs recently, so I know it's working.

    The moderators might slap the cuffs on this thread if it gets too productive.

  12. fireproofsocks
    Member
    Plugin Author

    Posted 11 months ago #

    Per your email: you need to update to the latest version (currently 0.9.7.6) before I can look at this -- there have been several bugs reported and fixed relating to URL handling.

  13. Araminho
    Member
    Posted 11 months ago #

    Sorry for confusion, I have already updated plugin (current version is 0.9.7.6), disabled again all others and tested with the default theme. The problem doesn't disappear. I just copied my old text, because the report stays the same.

  14. fireproofsocks
    Member
    Plugin Author

    Posted 11 months ago #

    Ok, I pasted this for you: https://code.google.com/p/wordpress-custom-content-type-manager/issues/detail?id=501

    Seriously, it's unbelievably inconvenient that you can't get into the bug-tracker: you won't get notified of any updates. I don't have any projects that require looking into this bug, so I'll get to it when I can, but as a rule, if a project requires custom URLs, WordPress is usually a bad option. MODX's handling of this is as close to perfect as I can imagine so fumbling through WP in this area is downright painful imo.

  15. Araminho
    Member
    Posted 11 months ago #

    Thanks, I have starred that issue and will get notifications.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic