WordPress.org

Ready to get started?Download WordPress

Forums

oAuth Twitter Feed for Developers
Empty Twitter feed (4 posts)

  1. Jellyfishboy
    Member
    Posted 8 months ago #

    Hi,

    Today my feed suddenly stopped working when I pushed the site to production. I have added the required access tokens from dev.twitter.com and even recreated them in the hope of fixing the problem.

    You can find my getTweets() method here:

    https://github.com/Jellyfishboy/tomdallimore/blob/master/wp-content/themes/tomdallimore/twitter.php

    You can also see it live here: http://tomdallimore.com/home/

    Is there any way I can debug this plugin to find the source of the problem?

    Any help appreciated!
    Tom

    http://wordpress.org/plugins/oauth-twitter-feed-for-developers/

  2. Liam Gladdy
    Member
    Plugin Contributor

    Posted 8 months ago #

    Did you update to this mornings release (2.1.2)?

    I notice you're using: $tweets = getTweets(3, billy_dallimore); - The string isn't a string there, it's a constant? It should be $tweets = getTweets(3, 'billy_dallimore');

    Though, as of 2.1 this morning, you should write it as:

    $tweets = getTweets('billy_dallimore', 3);

    The old way still works, but this is much more sensical :)

  3. Jellyfishboy
    Member
    Posted 8 months ago #

    Thanks for your prompt reply.

    Completely missed this; strange though it works on dev and not prod. I'll have a play and let you know the outcome.

  4. Liam Gladdy
    Member
    Plugin Contributor

    Posted 8 months ago #

    It is super weird! Maybe different PHP versions with different behaviour of constants?

    Thanks :)

Reply

You must log in to post.

About this Plugin

About this Topic