WordPress.org

Ready to get started?Download WordPress

Forums

Events Made Easy
[resolved] Causing problems with force_ssl_admin (12 posts)

  1. vvvv
    Member
    Posted 8 months ago #

    Hi, I have been having trouble getting my ssl pages & force_ssl_admin to work properly with eme. Anytime I am initiating force_ssl_admin, I get redirect loops on any page that is not designated as an https page.

    I have elimiated plugin by plugin and found that eme is causing the breakdown. Is there anything I can do to alleviate this? Any setting I need to know about to help use eme with my site? (This is happening on at least 2 sites.)

    I am using wordpress https to secure individual pages, but have also tried hardcoding wp-config with force_ssl_admin too. With eme activated, I get an infinite refresh of the http pages. (The https pages are working fine.)

    I like to continue using your plugin - really like it!, but I need to secure my admins too. Have you seen anything like this earlier?
    Thanks in advance.

    http://wordpress.org/plugins/events-made-easy/

  2. Franky
    Member
    Plugin Author

    Posted 8 months ago #

    So, to clarify: normal pages work fine, but the admin pages cause a redirect when using https via FORCE_SSL_ADMIN and eme?

  3. vvvv
    Member
    Posted 8 months ago #

    hmmm, not sure if I understand you, let me try again.

    I am using wordpress https to secure certain pages, that works ok.

    But when I want to secure the admin along with these pages( by using force_ssl_admin or by checking the box in the WPhtts plugin to force ssl admin), I get infinite refreshes on all of the pages that were to be delivered normally (all http pages).

    The https pages and the admin are correctly served as https, and with no refresh loop.

    Does that make sense?

  4. Franky
    Member
    Plugin Author

    Posted 8 months ago #

    I just need to understand the test scenario I need to reproduce :-)
    I'll try something this evening.

  5. vvvv
    Member
    Posted 8 months ago #

    Thank you so very much!

  6. Franky
    Member
    Plugin Author

    Posted 8 months ago #

    I just tested with
    define('FORCE_SSL_ADMIN', true);
    in wp-config.php on localhost: all works well, http and https, even multisites. So I think you need to use something like firebug (to debug network traffic when using firefox) to see what url causes the redirection.
    Also: check the value of "home" and "siteurl" in the wp_options table to make sure those are correct.

  7. vvvv
    Member
    Posted 8 months ago #

    Thank you for reviewing this. Just to check, I have wp installed in a subdirectory of the root, and both home and siteurl are defined to that subdirectory - is this the correct setup for the ssl to work?

    Using firebug network, I do not see the redirects, so it has been hard to track. All I do know, is that disabling eme makes the site work properly.

    Is there anything else I could look for? I will go over these again to make sure I havent missed anything.

  8. Franky
    Member
    Plugin Author

    Posted 8 months ago #

    In my test setup, both home and siteurl are set to:
    http://localhost/wordpress

    Sp maybe ssl isn't the cause at all, but maybe some rewrite rules?
    If you say that you see infinite redirects, you should see that with firebug as well, no?
    Can you provide a test setup where this behaviour happens, so I can check?
    You can mail me the url at liedekef [at] telenet.be ; I'll take a look at it tomorrow (1am here now)

  9. vvvv
    Member
    Posted 8 months ago #

    Finally! I was able to replicate this error on a new test site. I sent you the info just now.

  10. Franky
    Member
    Plugin Author

    Posted 8 months ago #

    I think the problem is related by the wordpress ajax method, the EME setting "use client clock" and the forced use of https in the admin backend: based on the code found in http://www.garyc40.com/2010/03/5-tips-for-using-ajax-in-wordpress/, I use admin_url to get the admin-ajax.php url (to learn the client time EME uses ajax), but since this might be https and the rest not, the generated php session id is not valid.
    So please try if this change fixes it:

    http://plugins.trac.wordpress.org/changeset/750528

  11. vvvv
    Member
    Posted 8 months ago #

    Yes yes yes yes !!

    I just updated it on 3 different sites and all are working! Thank you so very very much - I spent a month debugging this and always ended up in the admin-ajax area, but I didnt know enough to know where to go next.

    I'll let you know if I see any further problems, but for what I see now, this fixed the problem

    Thanks again!!

    Have a great weekend!

  12. Franky
    Member
    Plugin Author

    Posted 8 months ago #

    Glad to hear it works, it will be in the next version.

Reply

You must log in to post.

About this Plugin

About this Topic