WordPress.org

Ready to get started?Download WordPress

Forums

Embedded images and videos not showing in archive and category view (5 posts)

  1. zugu
    Member
    Posted 6 years ago #

    My blog is using the latest version of wordpress, 2.3.1, but the theme I use was made for the 2.1 branch. I noticed no problems until I switched to archive and category views.

    When viewing all the posts in a month or in a certain category, my posts show up without the images and videos embedded in the post body. It's like they're truncated to some text-only versions. I use external hosting services for images and videos (Flickr, YouTube, etc).

    If it helps, visit http://crumblenaut.net and notice how single posts and pages show up without any problem, yet when choosing a month or a category all the posts are suddenly text only. I tried reverting to the default Kubrick theme and the problem is not present anymore, yet I don't want to use the Kubrick theme. I would ask the author of the custom theme I am using, but her site is offline.

    Any help would be greatly appreciated. Thank you very much.

  2. yakuphan
    Member
    Posted 6 years ago #

    Open your archive.php in your theme or the file which shows your categories or archives.
    Find < ?php the_excerpt(); ?> code and replace following

    < ?php the_content('Read more... »'); ?>

    Please delete the space in < ?php
    the_exerpt() function shows the post without html tags.

  3. zugu
    Member
    Posted 6 years ago #

    Thank you thank you thank you thank you thank you thank you!

    It works now! You saved my blog!

  4. darelparker
    Member
    Posted 6 years ago #

    I was having the exact same problem with one theme in particular. Thanks!

  5. jakestapleton
    Member
    Posted 5 years ago #

    This community is outstanding! I was having the same problem with my church's wp site.

Topic Closed

This topic has been closed to new replies.

About this Topic