WordPress.org

Ready to get started?Download WordPress

Forums

Embed YouTube and Not show related video's when video is finished (31 posts)

  1. knssconsulting
    Member
    Posted 2 years ago #

    Does anyone know how to stop the related video’s from showing after a YouTube video on the

    The Stage Gallery at http://www.knssconsulting.com.previewdns.com

    Any posts…etc

    I know the code is

    ?rel=0

    After the video, but it just doesn’t seem to be working with this theme.

    I have tired

    http://www.youtube.com/watch?v=3SuNx0UrnEo?rel=0

    and this

    http://www.youtube.com/embed/3SuNx0UrnEo?rel=0

    as well as this long code I found on someone’s site

    http://www.youtube.com/v/3SuNx0UrnEo?version=3&hl=en_US&rel=0

    I would really appreciate the help to resolve this because I’m trying to prevent people bouncing off my site to go watch competitors video’s.

    Here is my webpage I’m trying to do it on

    http://knssconsulting.com.previewdns.com/?page_id=7

    Thanks

  2. It's not ?rel=0... it's &rel=0

    Note you were using a question mark. It should be an ampersand.

  3. knssconsulting
    Member
    Posted 2 years ago #

    Hi Josh,

    I am going by YouTube's new code now

    <iframe width="560" height="315" src="http://www.youtube.com/embed/Y0V8Mlr2ANY?rel=0" frameborder="0" allowfullscreen></iframe>

    if you look at it now

    it is ?rel=0

    I tried the &rel=0

    as you recommended but the video now wouldn't play

    here I left it up for you to see

    http://knssconsulting.com.previewdns.com/?p=367

  4. NeilGinger
    Member
    Posted 2 years ago #

    Hi I have exactly the same problem and have tried the same solutions as above with the same results.
    Would love to know the solution...

  5. @knssconsulting,

    Here is the iframe code you are using:

    <iframe width="960" height="500" frameborder="0" allowfullscreen="" src="http://www.youtube.com/embed/?autoplay=0&loop=0&wmode=opaque&title=" marginwidth="0" marginheight="0"></iframe>

    Try this instead:

    <iframe width="960" height="500" frameborder="0" allowfullscreen="" src="http://www.youtube.com/embed/?rel=0&autoplay=0&loop=0&wmode=opaque" marginwidth="0" marginheight="0"></iframe>
  6. knssconsulting
    Member
    Posted 2 years ago #

    Hi Josh,

    I tried posting your code and nothing happened.

    I don't think I am using an iframe

    Here is the code from what I can find from the video

    [videoembed type="youtube" align="aligncenter" width="960" height="500" url="http://www.youtube.com/watch?v=Y0V8Mlr2ANY&rel=0" id="video-0"]

  7. knssconsulting
    Member
    Posted 2 years ago #

    Hi Neil,

    Yeah for some reason WordPress and the theme developers have not made it easy to work with YouTube and their coding.

    Let me know if you find anything Neil

  8. I thought you were inserting this via HTML.

    What button are you using to insert the video?

    Try switching to the html view and try my code above again. Just to see if it works.

  9. knssconsulting
    Member
    Posted 2 years ago #

    Hi Josh,

    I did copy the code below of mine from the HTML view

    [videoembed type="youtube" align="aligncenter" width="960" height="500" url="http://www.youtube.com/watch?v=Y0V8Mlr2ANY&rel=0" id="video-0"]

    As well I copied and pasted your code above in the HTML editor and saved it

    <iframe width="960" height="500" frameborder="0" allowfullscreen="" src="http://www.youtube.com/embed/?rel=0&autoplay=0&loop=0&wmode=opaque" marginwidth="0" marginheight="0"></iframe>

    Here is the link so you can see

    http://knssconsulting.com.previewdns.com/?p=367

  10. knssconsulting
    Member
    Posted 2 years ago #

    Hi Josh,

    any luck?

  11. NeilGinger
    Member
    Posted 2 years ago #

    This is really frustrating, I am searching all over for a solution still no luck.

  12. knssconsulting
    Member
    Posted 2 years ago #

    I was hoping the WordPress Support Team would chime in and maybe they know a fix?

  13. NeilGinger
    Member
    Posted 2 years ago #

    The only thing i am able to do at the moment is put a pause on the end of the video but that is not really a fix.

  14. knssconsulting
    Member
    Posted 2 years ago #

    A trick I learned, which I didn't really want to do is, you leave a splash screen at the end with your logo and how to contact you at the end of the video. let it run for 5 seconds or so. So people think the video's is down and stops there.

    It is a really bad work around but that is one way of doing it.

    Hopefully a WordPress happy engineer chimes in. But I think these issues are Theme specific because my wordpress.com works fine. I copied the code from there and not it doesn't work which makes me think it's the way the theme's have been coded.

    What do you think?

  15. NeilGinger
    Member
    Posted 2 years ago #

    I am using themeforest 533913 Corona Business Portfolio Theme. Which theme are you using? From what your saying I would agree this does seem to be theme specific.
    Lets hope someone can help us.

  16. knssconsulting
    Member
    Posted 2 years ago #

    I am using Tersus from Theme forrest, it's a great Theme a few bugs. but I'm loving the options.

    I agree hopefully someone can help us a as well. Especially because of Youtube

  17. NeilGinger
    Member
    Posted 2 years ago #

    ok so Theme forest has an issue with video on You Tube it would seem. have you had any contact with Theme Forest re this?

  18. I am using themeforest

    ...

    I was hoping the WordPress Support Team would chime in and maybe they know a fix?

    For support of Themeforest themes, you really do need to go back to them as get support there.

    http://themeforest.net/

    While generic advice is always available, please be aware that no one has access to commercial themes here. And honestly we don't want access, support is part of what you paid for when you purchased your theme.

    It's not for us here to undercut the theme providers business model and they should have no problem supporting you with your theme problems.

    Generically speaking, Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    - re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress.

    Also read the Master List for 3.4

    http://wordpress.org/support/topic/troubleshooting-wordpress-34-master-list?replies=5

  19. knssconsulting
    Member
    Posted 2 years ago #

    Thanks Jan,

    I did contact Themeforest.net and they told me I had to contact the developer of the theme because they do not provide support.

    ---

    -There are no plugins installed it is a new installation of the theme.
    -Switching to Twenty Eleven didn't change anything.

    The Master list for 3.4 does not talk about video/Youtube.

    Thx Jan but I know there is someone out there that has a WordPress.org blog that has had this issue and resolved it.

    Thx

  20. Michael
    Member
    Posted 2 years ago #

    I don't think you have control over the "related videos" on YouTube.

    http://support.google.com/youtube/bin/answer.py?hl=en&answer=92651

    Michael

  21. Felix Renicks
    Member
    Posted 2 years ago #

    You almost had it with the iframe code, but you missed out the video ID! Stick this in the HTML tab of the editor:

    <iframe width="960" height="500" frameborder="0" allowfullscreen="true" src="http://www.youtube.com/embed/Y0V8Mlr2ANY?rel=0&autoplay=0&loop=0&wmode=opaque" marginwidth="0" marginheight="0"></iframe>

  22. knssconsulting
    Member
    Posted 2 years ago #

    You are awesome Felix

    Hey NeilGinger,

    I tested it a few times and it worked amazing here is an example

    http://knssconsulting.com.previewdns.com/?page_id=7

    Thank you so much Felix,

    Do you have any other YouTube tricks for blogs you can share?

    Thx

  23. Felix Renicks
    Member
    Posted 2 years ago #

    You're very welcome!

    Here is the list of allowed parameters. You can use any of these that list HTML5 under "supported players"; just add them to the URL in the same format as the others, eg &name=value

  24. knssconsulting
    Member
    Posted 2 years ago #

    That's awesome!

    Thank you so much it has been a few days of trying to figure this out.

    Thx

  25. knssconsulting
    Member
    Posted 2 years ago #

    Oh Felix,

    How do you add the other parameters into the code?

    for example "autohide" and "controls"

    I would like the video to look like this one

    http://themeforest.net/item/tersus-responsive-wordpress-theme/full_screen_preview/2343187

    Main widget, 4th slide in?

    I am not a coder so please speak in simple terms and make it user friendly :-)

    Thx

  26. Felix Renicks
    Member
    Posted 2 years ago #

    Try this:

    <iframe width="960" height="500" frameborder="0" allowfullscreen="true" src="http://www.youtube.com/embed/Y0V8Mlr2ANY?rel=0&autoplay=0&loop=0&wmode=opaque&controls=0&showinfo=0&theme=light" marginwidth="0" marginheight="0"></iframe>

  27. knssconsulting
    Member
    Posted 2 years ago #

    I tried this code for the "autohide" and "controls"

    <iframe width="900" height="500" frameborder="0" allowfullscreen="true" src="http://www.youtube.com/embed/3SuNx0UrnEo?rel=0&autoplay=0&autohide=2&controls=0&loop=0&wmode=opaque" marginwidth="0" marginheight="0"></iframe>

    but didn't seem to work to do the above

    http://knssconsulting.com.previewdns.com/?page_id=7

    plus how do you make the video play without the black boarders on the left and right hand side of the video?

  28. knssconsulting
    Member
    Posted 2 years ago #

    Hi Felix,

    I tried your code above

    http://knssconsulting.com.previewdns.com/?page_id=7

    but it's still showing the controls on the bottom and the black lines on each side

    This is what I copied

    <iframe src="http://www.youtube.com/embed/3SuNx0UrnEo?rel=0&autoplay=0&loop=0&wmode=opaque&controls=0&showinfo=0&theme=light" frameborder="0" marginwidth="0" marginheight="0" width="900" height="500"></iframe>

    did I do it wrong?

  29. NeilGinger
    Member
    Posted 2 years ago #

    I have found another simple fix. In You tube embed code if you tick use old embed code in the options it works fine.
    Best wishes
    Neil

  30. Rick F
    Member
    Posted 1 year ago #

    One thing to note regarding Themes. Another way to find out if a Theme is affecting something is to switch to a default WordPress theme like 2010 and see if that changes anything. In my case doing the ?rel=0 still did not work. Just sayin.

Topic Closed

This topic has been closed to new replies.

About this Topic