WordPress.org

Ready to get started?Download WordPress

Forums

Embed Google map problem! (5 posts)

  1. phuile
    Member
    Posted 3 years ago #

    I need to embed Google maps onto a WordPress page, and I want all the maps to be embedded align right. So I position the embed code at the appropriate places and set the algin to "right". The maps now algined right, but the "View larger map" link is not aligned right. So there is a block of my text, white gap (space) where the map is aligned right, then the "View larger map" link not aligned right after the gap, then the rest of my text.

    I see the that </iframe> only enclosed the map but not the "View larger map" link code. Is that the problem? And how can I solve this?

    I just want the map with the "View Larger Map" link under it, both aligned right.

    Please help!

  2. molnarm
    Member
    Posted 3 years ago #

    "I see the that </iframe> only enclosed the map but not the "View larger map" link code. Is that the problem?"

    Yes.

    "And how can I solve this?"

    Just wrap the whole thing in a div:

    <div style="text-align:right";>
    map stuff (iframe + link)
    </div>
  3. phuile
    Member
    Posted 3 years ago #

    Thanks, molnarm. I tried that and the link ended up in the middle - so block of text on the left, the link in the middle, the map on the right. What I ideally want is the link to the below the map on the right (since the map is on the right).

    I tried just enclosing the iframe + link within a simple <div>, without the style. In that instant, the link appear on the left above the block of text before the right aligned map in the iframe, even though the code for the link is "written" below the iframe. Does anyone know why that is?

  4. molnarm
    Member
    Posted 3 years ago #

    I just found out that the link tag has text-align set to left, which overrides previous settings. Delete that attribute and try again with a right-aligned div.

  5. phuile
    Member
    Posted 3 years ago #

    I have already tried deleting it (so the alignment is solely from the div style, and changing it to "right" but both gave similar results to what I described ... so I still haven't been able to solve this.

Topic Closed

This topic has been closed to new replies.

About this Topic