WordPress.org

Ready to get started?Download WordPress

Forums

Embed Flash with Kimili Flash Embed? (25 posts)

  1. redwolf
    Member
    Posted 9 years ago #

    I’m trying to embed the resulting SWF from SlideShowPro into a “page� (WP 1.5.3), but all I get is what looks like the outline of it…any suggestions? My pathing is correct (http://www….) and I have double and triple checked my syntax (< kml_flashembed movie="http://www.brighteyespets.com/gallery/slideshow.swf" height="400" width="385"></kml_flashembed >). I really need this to work!

  2. seanshaghaghi
    Member
    Posted 9 years ago #

    Have you tried using a relative url instead of an absolute one?

    I have the following and it works fine for me:
    <kml_flashembed movie="/folder/slideshow.swf" height="400" width="450"></kml_flashembed>

    You can see an example here: http://www.shaghaghi.net/pixel/

  3. grimmet
    Member
    Posted 9 years ago #

    lol, the internet is absolutely fantastic. =)
    today i bought a copy of slideshowpro, build my first slideshow and started to integrate the result in my WP. after a while i found the kimili-flash-plugin, but the slideshow wont show up...
    (really, i thought in this combination, iam the only one who tried it) but than i found this thread.
    all in all:
    my slideshow doesnt work, yours shaghaghi, works well.
    take a look: http://www.nicolasoestreich.net/08/2004/test/
    and if i loud my slideshow seperately, all is fine... this is very tricky.. regards nicolas

  4. grimmet
    Member
    Posted 9 years ago #

    ok i found the sollution.
    in the settings in flash , you have to point to the xml file not relative but directly!

  5. Gilbert
    Member
    Posted 8 years ago #

    I am new to wp. I just downloaded the kimili-flash plugin, and I wrote
    <kml_flashembed movie="index.swf"
    height="150"
    width="300" ></kml_flashembed>
    in text box for the post, but it does not do anything. I guess I should put that tag somewhere else?

    Any help?

    Thanks,

    Gilbert

  6. paulcaridad
    Member
    Posted 8 years ago #

    Will "Kimili Flash Embed" help with posting a "XSPF Web Music Player"? I want to be able to use xspf web player in my posts.

    http://www.kimili.com/journal/39/kimili-flash-embed---wordpress-take-3
    http://musicplayer.sourceforge.net/

  7. Boriel
    Member
    Posted 8 years ago #

    redwolf:

    I've made a plugin to embed XSPF MP3 Player into wordpress.
    See: http://www.boriel.com/?page_id=12

    Perhaps it suits to you.

  8. leconfit
    Member
    Posted 8 years ago #

    I noticed Gilbert's post above and he seems to have succeeded in getting his swf to show up in his post -- but I can't see that anyone else has been successful.

    I have downloaded the updated Kimili plug-in and the updated syntax does not seem to work either:

    [kml_flashembed movie="filename.swf" height="250" width="400" /]

    Anyone figure out the flash embed thing reliably yet?

  9. gixbecks
    Member
    Posted 8 years ago #

    me too, it works for me before, but i just try to post another one and the post shows error:

    Warning: join(): Bad arguments. in /home/giamourcom/domains/giamour.com/public_html/gblog/wp-content/plugins/kml_flashembed.php on line 313

    anyone had a clue?
    thxx

  10. ppurvis
    Member
    Posted 8 years ago #

    I too am having trouble. I have quadruple checked my code:
    [kml_flashembed movie="/wp-content/uploads/2006/04/greece.swf" height="300" width="300" /]
    The swf file is definately there and the plugin activated.
    All suggestions welcome!

  11. strugglefish
    Member
    Posted 8 years ago #

    This pluging appears to be broken, the embed code as mentioned above just prints out to the page you inserted it on. Any ideas?

  12. opq
    Member
    Posted 8 years ago #

    i cant seem to get version 1.1 of the plugin to work etiher. ive checked everything but I get a javascript error on the page i embed. "FlashObject is not defined". Anyone ever gotten this plugin to work?

  13. alistairnelson
    Member
    Posted 8 years ago #

    Hi

    I have the same problem, embeded code just displays on the post instead of flash content. Any help?

  14. Kimili
    Member
    Posted 8 years ago #

    Hi everybody -

    Those of you that are seeing the KFE tag code output to your site rather than the flash content, know that it is due to an incompatibility with the plugin and using GZIP compression in your WP settings.

    For more info, see the FAQs on the Kimili Flash Embed Home Page

  15. alistairnelson
    Member
    Posted 8 years ago #

    Thanks Kimili, I certainly did read through your FAQ but missed that one somehow. Thanks for volunteering your time!

    Now I have a new, stupid problem. I simply get nothing. My codes there, but nothing at all is output. I tried for example:

    test
    [kml_flashembed movie="http://www.craigtrewin.com/images/FrontSlides.swf" height="200" width="300" /]
    test

    and the output was just

    test
    test
    ...no flash outline or anything.

    Anyone any ideas? It seems the code is at least being parsed now by the plugin. I can access the URL directly so I know the file is there.

  16. Kimili
    Member
    Posted 8 years ago #

    Alistair - Are you getting any javascript errors? The plugin creates a link to an external javascript file, and perhaps the pathing to that file is incorrect in your case. If so, you would see errors along the lines of "FlashObject not defined".

  17. alistairnelson
    Member
    Posted 8 years ago #

    Hi Kimili,

    No errors unfortunately, on screen or in ~/error_log

    Theme is painted-desert-1 which just has an index.php, no sidebar.php. It's WordPress 2.03 installed by bluehost fantastico.

    I have tried Martin Laine's audio player plugin which uses similar [ ] syntax, and that works ok. I have also disabled all plugins except KFE and it still has the same problem.... parses the request but no output at all.

    Maybe for some reason there are errors and I aren't seeing them. Is this javascript file "flashobject.js" ? If so where should it be?

  18. alistairnelson
    Member
    Posted 8 years ago #

    still stuck on this. Anyone any ideas?

  19. alistairnelson
    Member
    Posted 8 years ago #

    ^ Ahem

  20. alistairnelson
    Member
    Posted 8 years ago #

    Michael got this working for me. I had to:

    - put the kml_embed php file directly in the plugins folders and not in the default unzipped folder
    - put line breaks before and after the KFE tag

    thanks

  21. chrishungate
    Member
    Posted 8 years ago #

    I'm having the same issue. Using SlideShowPro, I've tried every proposed solution on this page.

    I'm trying to embed my Flash movie into a Page, not a post, but in your FAQ, Kimila, you say that version 1.1 now supports embedding in Pages (and I'm using version 1.1, WP 2.0.4)

    Kimila, you said:

    Alistair - Are you getting any javascript errors? The plugin creates a link to an external javascript file, and perhaps the pathing to that file is incorrect in your case. If so, you would see errors along the lines of "FlashObject not defined".

    Yet on your site you say that the Javascript is now embedded into the PHP document, so that can't be the reason, can it?

    I am getting the "FlashObject not defined" JavaScript error, so maybe it's not embedded or for some reason WP isn't picking up on it?

    Could it have anything to do with the K2 theme I'm using?

    Here's my tag:

    [kml_flashembed movie="http://www.chrishungate.com/wordpress/flash/slideshow/slideshow.swf" height="428" width="375" /]

    and the URL works on its own so I know that everything's working with the Flash file. The darn thing just won't show up on my Page.

    Please help if you can...anyone?

  22. MikeBlyth
    Member
    Posted 8 years ago #

    For what it's worth, I was having the same sorts of problems listed here, either nothing showing up on the page or the tag itself appearing in the HTML source instead of being processed. It turned out that I had somehow downloaded a quite old version (0.something) even though it was just yesterday that I found it. So it pays to check your version. (I found the old version worked when I used embedflash rather than kml_embedflash for the tag name.)

  23. EcoGraphic
    Member
    Posted 7 years ago #

    I am using the latest version of the Kimili Flash Plugin on WordPress 2.0.4

    Put your flash .swf file into the root of your site, and use this as your code:

    [kml_flashembed movie="/intro.swf" height="390" width="500" /]

    Make sure you have the "/" before the flash file name, even though it is just in your site root.

  24. calcrat
    Member
    Posted 7 years ago #

    I found my error - thanks to a guy on the runPHP forum..... try this, if you are using a non-default wordpress theme:

    1. Change back to the default theme. If it works, you know the theme is part of the issue (it was for me).
    2. Check to make sure your theme header.php file includes this line:
    <?php wp_head(); ?>
    3. If that doesn't fix it, compare the php files for the default theme versus your custom themes.

  25. dazzlegas
    Member
    Posted 7 years ago #

    I have gzip compression turned off, but my flash is only showing up about 50% of the time with this plugin.

    The other 50% of the time, I just get the "KLM-flash embed" tag showing up in the page instead.

    I'm using the latest version of wordpress along with KLM 1.1.

    When the flash shows up, it's working fine.

    Any thoughts?

Topic Closed

This topic has been closed to new replies.

About this Topic