WordPress.org

Ready to get started?Download WordPress

Forums

Subscribe2
[resolved] Emails Sending to Admin Only (17 posts)

  1. emoshun
    Member
    Posted 1 year ago #

    I have an active subscriber list loaded in the plugin, yet my posts are only being emailed to the admin account.

    Please help, thanks!

    http://wordpress.org/extend/plugins/subscribe2/

  2. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @emoshun,

    Install a mail logging plugin like those listed below and see if the additional mails are being generated:

    http://wordpress.org/extend/plugins/email-log/

    http://wordpress.org/extend/plugins/wp-mail-log/

    There is little more that I can suggest based on such brief information.

  3. emoshun
    Member
    Posted 1 year ago #

    What check boxes should be checked if I want to ensure a send is delivered to my entire "public subscribers list" and not just the admin's email.

    I can provide you with user/pass if necessary to see what I am missing.

    The mail log plugin that I have installed is showing only one email sent.

    Thanks!

  4. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @emoshun,

    In the Subscribe2->Settings page, set the number of recipients per email to 1. I suspect that at the moment this value is 0 so you recipients are in an email header called BCC rather than the TO field.

    Changing that value to 1 will at least give you a more detailed log.

  5. emoshun
    Member
    Posted 1 year ago #

    It has been set to 1 this entire time.

    Not sure what else to do, would you have a moment to look into our settings?

    Please let me know!

    Thanks,

    James

  6. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @emoshun,

    I'm a bit tied up with too many other things at the moment.

    Are these scheduled posts you are making or are you manually hitting "Publish"?

    Also, you could link to a screen shot of your settings - that might be quicker at the moment.

  7. emoshun
    Member
    Posted 1 year ago #

  8. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @emoshun,

    Thanks. At first glance that all looks fine. And the question about scheduling? Also, who is the hosting provider?

  9. emoshun
    Member
    Posted 1 year ago #

    Posts automatically when a new article is posted.

    Bluehost is the provider, I can provide all details to help solve this.

  10. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @James,

    I'm not entirely sure what you mean when you say automatic but if this uses WordPress scheduled events at all there does seem to be an issue on Bluehost at the moment. The fix is to add this line to you wp-config.php file:

    define('ALTERNATE_WP_CRON', true);

  11. emoshun
    Member
    Posted 1 year ago #

    Still didn't work, email did not go out as scheduled.

    Please help!

  12. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @James,

    Can you explain in more details what you mean by: "Posts automatically when a new article is posted."

  13. emoshun
    Member
    Posted 1 year ago #

    When you posted a new article the post used to automatically go out to subscribers as scheduled in the subscribe2html setup.

    To further clarify, you didn't have to manually go in and click something to make it send the last post to all subscribers.

  14. Cherissa
    Member
    Posted 1 year ago #

    Hi, I'm actually involved on this project too - we appreciate your help to resolve. We've tried both "scheduling the posts" and just hitting "publish", doesn't seem to make a difference. Subscribe2html notification still only goes out to 1 email address - not full subscriber list. it looks perfect with the html/excerpt formatting we want, just not going to everyone on our list.

    I found a similar post about messages not going out to subscribers all of a sudden, but we only have 47 public subscribers. The 1 email is my previous programmers ADMINISTRATOR login (which is my email) it is the FIRST email listed under our REGISTERED SUBSCRIBERS LIST.

    If he had done any sort of hack to the plugin we would have removed when emoshun uninstalled/reinstalled the plugin. Is there any other place within wordpress that it could override your plugin like that?

    We've spent a lot of time trying to workout a fix and the client is ready to just drop the plugin. I'd love to figure out and keep using the plugin! Thanks for your time!

  15. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @Cherissa,

    To be honest, at this point I think we are only going to get some progress in resolving this by me taking a look. Please can you contact me here:

    http://www.prescriber.org.uk/contact.php

    And we can arrange a login for me to use to have a look over your site.

  16. Cherissa
    Member
    Posted 1 year ago #

    Wonderful. Sent as requested. Thank you!!

  17. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @Cherissa,

    I sent you a response a few hours ago, I think your issues are being caused by the fact that you've excluded all categories in the Settings page - this stops Public Subscribers from getting emails in those categories and it would stop Registered Subscribers too but you've enabled the over ride for them.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic