WordPress.org

Ready to get started?Download WordPress

Forums

Subscribe2
[resolved] Emails not working (12 posts)

  1. SammyS
    Member
    Posted 1 year ago #

    Hi,
    I just installed the PlugIn and tried to subscribe myself with an email that is not subscribed yet, it doesn't work tho.
    I went through the posts here and checked everything but I still don't get it fixed.

    So I created a page, added the form by clicking on that s2 button and linked that page to the subscriber settings as well as the widget.
    The "send e-mail from" author thing is correct too (I had that error msg first that it doesn't fit to the domain, but I fixed it) and the SMTP is smtp.paperflutterby.de.

    Yet, when I try to subscribe myself the subscribtion form page simply reloads again and nothing else happens, no email received, no msg about new subscriber etc.

    What am I doing wrong?

    Here's my website: http://paperflutterby.de/?

    http://wordpress.org/extend/plugins/subscribe2/

  2. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @SammyS,

    The input is not being processed at all by your site. Are you running any sort of caching in WordPress? Is so you need to try with it turned off.

  3. SammyS
    Member
    Posted 1 year ago #

    Not that I know of. I'm not even sure what that means.
    I only have the timthumb cache if that counts?

  4. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @SammyS,

    That would count, disable it in the Plugins page and try the Subscribe2 form again.

  5. SammyS
    Member
    Posted 1 year ago #

    I can't, it's not a PlugIn like that. It comes with the theme.
    Bascially it's the timthumb.php that needs a cache folder in the directory to make pictures look pretty on websites.
    You really think that could be the problem?

    The only PlugIns I have installed are
    Hello Dolly, Jetpack, kk Star Ratings, Like-Button-Plugin-For-Wordpress and your Subscribe2. Any of them knowingly causes problems?

  6. SammyS
    Member
    Posted 1 year ago #

    I deactivated all PlugIns and deleted the timthumb.php plus cache folder from the directory, but it still does not work :/

  7. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @SammyS,

    Try switching to one of the core WordPress themes to test, if that works then it's something in the theme.

  8. SammyS
    Member
    Posted 1 year ago #

    Damn. It really is the theme. Totally gonna contact their support.
    Thanks for your help!

  9. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @SammyS,

    A little step closer to a solution - at least you know the cause.

  10. SammyS
    Member
    Posted 1 year ago #

    Hi Matty,

    so I talked to their support and indeed it is a problem with their styled buttons (javascript) thing. It produces a nice hover effect to buttons which I actually quite like and don't want to remove (which would be one way to solve the problem they said).

    They told me another option would be to look in the plugin code for where the plugin is outputting form submit buttons and then add the “noStyle” class to the appropriate HTML or PHP code.
    Something like <button class="noStyle">My button</button>.

    So if I wanted to add that class to the form buttons where would be that code and would it be possible even?

  11. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @SammyS,

    That's possible. Have a look in the Subscribe2 folder on your server in the classes folder and you'll find a file called class-s2-frrontend.php. You need to look for the three lines where $this->input_form_action is defined and add the class to the variable on those lines. The first instance currently looks like this:
    $this->input_form_action = "<input type=\"submit\" name=\"unsubscribe\" value=\"" . esc_attr($unsubscribe_button_value) . "\" />";

    You will need to cahnge that to:

    $this->input_form_action = "<input class=\"noStyle\" type=\"submit\" name=\"unsubscribe\" value=\"" . esc_attr($unsubscribe_button_value) . "\" />";

  12. SammyS
    Member
    Posted 1 year ago #

    Awesome, it worked! Thank you so much!
    (it were four lines I had to change, 2x subscribe & 2x unsubscribe)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.