WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
Emails not sending (39 posts)

  1. Catinthefridge
    Member
    Posted 1 year ago #

    My new posts are no longer going out to my subscribers!

    http://wordpress.org/extend/plugins/jetpack/

  2. louiseallan
    Member
    Posted 1 year ago #

    How come it takes so long for a response? This post is 2 days old...

    I have the same problem -- subscribers were being emailed of new posts and it was working fine, but latest post not sent. I'm a little frustrated as this is the third time this has happened and I've done nothing to change anything in the interim.

    Website: louise-allan.com.

  3. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    @Catinthefridge Could you post your site URL here, so I can have a look?

    If you want it to remain private, you can also contact us via this contact form:
    http://jetpack.me/contact-support/

    @louiseallan I checked our email logs for a few of your subscribers, and it seems that they all received a notification email about your latest post, on May 14 at 06:02 UTC. If some of your subscribers did not receive the email, could you send me their email address via this form, so I can have a look at our logs?

  4. louiseallan
    Member
    Posted 1 year ago #

    Jeremy, It did not initially send the emails to subscribers when I published the posts. I had to revert to Draft and Publish again and the second time, they sent. This has happened with the last two posts. Why is this happening?

    Also, it is not automatically sending the notification to Twitter.

  5. Monkeyboy
    Member
    Posted 1 year ago #

    I'm having a similar problem. The post I published today doesn't seem to have gone out to email subscribers. I check this by subscribing with my own email, and I haven't received anything, so I assume others haven't either.

    My url is: http://bananasaboutmovies.com

  6. Monkeyboy
    Member
    Posted 1 year ago #

    I've done a similar thing to louise. Returned the post to draft status, republished it, and the emails were sent.

  7. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    I checked both sites, and your Jetpack connection seems to be working properly.

    Do you use any plugins that may affect the status of your posts, or copy / clone existing posts?

    Could you both walk me through the steps you followed to publish your last post?

    Thank you!

  8. Catinthefridge
    Member
    Posted 1 year ago #

    Hi there, sorry was out of town! The issue spontaneously resolved itself 2 days after I posted here, and worked fine for a week. This morning, my new scheduled post did not go out via email again. My URL is http://catinthefridge.com

  9. Catinthefridge
    Member
    Posted 1 year ago #

    Oh! same thing. I reverted to draft, published again, and the emails got sent. Strange....

  10. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Could you all try to publish a new post, and let me know if the problem happens again?

    Thanks!

  11. sterumbelow
    Member
    Posted 1 year ago #

    Same problem for me.

    http://www.opinionatedworld.co.uk

    Posts were working fine last week, now emails are not sending out (I'm subscribed).

  12. sterumbelow
    Member
    Posted 1 year ago #

    I went back to draft and then re-published and it sent out the email. Very frustrating.

    While we're on the subject of Jetpack and new post emails - why is it still not possible to send just an extract of the article? I want people to read my posts on the website, not in their email - where they also format terribly. Can we expect this functionality soon?

  13. louiseallan
    Member
    Posted 1 year ago #

    I have noticed something that might be useful, Jeremy: My last post sent emails to subscribers the first time I published it. The only difference between that one and the others, was that I uploaded it on the day I published it. I still revised it many times before publishing, but I uploaded it that day. It seems that anything that I upload and save as a Draft for a day or two before I publish, does not get emailed to subscribers when I publish, but once I save it as a Draft again and republish it gets sent. I'm looking forward to hearing the solution.

    By the way, none of my posts are ever sent straight to Twitter. I'm having to do that manually each time. Do you cover that, or do I need to post that problem elsewhere?

    Oh, and one more thing: I, too, would like to be able to send an extract only to email subscribers and not the whole post. Just something else to think about...

  14. sterumbelow
    Member
    Posted 1 year ago #

    In response to Louise, I created my post on the same day as publishing. Publishing as soon as I'd finished writing it. I still had the problem...

  15. cyphog
    Member
    Posted 1 year ago #

    Same problem here.

    2 out of 4 posts published in the last two weeks have not sent out email notifications to subscribers.

    Extremely frustrating, and we're doing nothing out of the ordinary on our end. Write post -> publish -> random or no emails to subscribers.

    Edited to add: Also reverted latest post to draft and then republished. Took two times doing it (waiting a few minutes apart each time) for the email to go through. Second time I changed the original posting time. Not sure if that was the difference maker, but still frustrating that things aren't working as expected.

  16. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    cyphog:

    I think the issue may have to do with a mismatch with your siteurl and homeurl settings. Can you let me know what you have in your "WordPress Address (URL)" and "Site Address (URL)" boxes, in Settings -> General?

    sterumbelow:

    Hmm, everything seems fine with your site. Would you happen to have the email address of someone who definitely did not get your post by email? I can check on our end. Please send it to support@jetpack.me and link to this thread; don't post it here. :)

    louiseallan:

    same with you, everything seems fine on your site. Can you do the same as I asked from sterumbelow? As for sending only an excerpt of your post by email, you can do so if you include the Read More tag. Only what's before the tag will be sent by email. Note that this may change how posts are displayed on your site, depending on the theme.

  17. sterumbelow
    Member
    Posted 1 year ago #

    Richard, I've sent you an email to the specified address.

    I'm pretty sure that nobody received the new post email - and I know for certain two addresses didn't (both in the email I sent over).

    As for the extract stuff, is support for this coming without the need for using the "read more" tag?

    It seems like it should be a pretty easy thing to implement, considering how complex Jetpack itself is!

  18. cyphog
    Member
    Posted 1 year ago #

    Richard - email sent.

    Thanks!

  19. sterumbelow
    Member
    Posted 1 year ago #

    Sorry for the additional message - I've just tried out the more tag as you suggested, Richard.

    Thankfully, my theme seems to support this well. The more tag doesn't show inside the post but it does limit the extract on the homepage and presumably will in an email too - hopefully.

    Thank you.

  20. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Hi Sterumbelow and cyphog,

    I will try to get to your emails today, thanks!

    Sterumbelow, regarding using the excerpt or notin the emails, we try to keep things as simple as possible and for the widest use possible without adding too many options. Have a look at this earlier thread for a similar discussion:

    http://wordpress.org/support/topic/sending-full-post-in-email-despite-more-tag?replies=9

    However, if you feel strongly about it, I encourage you to file a Trac ticket here:

    http://plugins.trac.wordpress.org/newticket?component=jetpack

    And we'll take another look at it. Thanks!

  21. russell@irondogmedia.com
    Member
    Posted 1 year ago #

    Having issue with the subscribe to comments emails as well. We have received reports from people signing up to follow comments on a post, but they are not receiving the notification emails when a new comment is added.

    Here is the site GeneralAviationNews.com

    Functionality currently deactivated to reduce frustration, but I can turn it back on if you feel you have a fix in place.

    jetpack version 2.2.1 and wordpress version 3.5.1

    Thanks!

  22. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    @Russell As Richard mentioned above, could you send us a few examples of the email addresses that didn't receive any notification of new comments on one of your posts?
    http://jetpack.me/contact-support/

    Thank you.

  23. Barbara Joy
    Member
    Posted 1 year ago #

    I am having the same issue. Randomly of course....Some posts get an email notification and some don't. I have also heard from some subscribers who haven't been getting them, but others have. I'm at a loss....suggestions anyone? site name: middlesage.com thanks all!

  24. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Hi! You mentioned on Facebook that you use Jetpack, yet that site does not seem to be connected to WordPress.com properly. Can you do the following, please:

    1) turn off WP Super Cache
    2) Disconnect Jetpack from WordPress.com in your dashboard
    3) reconnect Jetpack to WordPress.com
    4) let me know when you've done that so I can verify the connection. :)

  25. PierM
    Member
    Posted 1 year ago #

    http://piermarton.info/
    Same issue: some posts leave, some don't.
    Before May 19, no problem then on May 19 a post does not leave.

    Tonight (May 23) a "test" went out as an e-mail, but later one real post (twice) did not make it - after re-drafting & re-posting.

    Erratic & undependable behavior...
    I can post the header of the successful mail tonight if that would be helpful.
    Thank you!

  26. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Hi PierM,

    Could you post your site URL here, so I can have a look?

    If you want it to remain private, you can also contact us via this contact form:
    http://jetpack.me/contact-support/

  27. PierM
    Member
    Posted 1 year ago #

    http://piermarton.info/
    I had posted it above, but I can also, if that would be helpful post the header of a successful e-mail onto that support page onto that contact form you gave me.
    Thank you Richard.

  28. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Pier,

    I'm sorry I didn't notice your URL above!

    I looked at your site's connection, and everything looks normal. Yes, the headers could definitely be useful, please go ahead and send those in, along with links to the successful and unsuccessful posts. Thanks!

  29. PierM
    Member
    Posted 1 year ago #

    Thank you, Richard. I sent the header and the links that never generated e-mails to your contact page: http://jetpack.me/contact-support/
    Thank you.
    Pier

  30. louiseallan
    Member
    Posted 1 year ago #

    Same issue -- email did not send to any subscribers until I saved it as a Draft and re-published. I had the post sitting for two days before I published it. As I said in an earlier comment, the emails only seem to not go when I publish posts I have saved for a day or two before publishing. Posts that I publish more-or-less immediately seem to send to subscribers.

    I will email an address to you that did not receive the post (my own).

    It is getting a little tedious...

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags