WordPress.org

Ready to get started?Download WordPress

Forums

MailPoet Newsletters
[resolved] Emails not being sent anymore (4 posts)

  1. tinuviel
    Member
    Posted 1 year ago #

    Running the latest version of WordPress, and the latest updated version of the plugin. 9 emails sent successfully since install.

    However, since just over a month ago, no new posts have been sent. I have not changed any server settings, nor any settings in the plugin.

    Any reason why this may be happening?

    http://wordpress.org/extend/plugins/wysija-newsletters/

  2. Ben
    Member
    Plugin Author

    Posted 1 year ago #

    Hello there,

    Can you send test emails ? From Wysija > Settings > Send with... ?

    If you can't send test emails well then try to change the sending method, maybe you should go for a third party SMTP. Maybe your host has block your email server.

    If the sendtest email works fine, then that means it's the automatic sending which doesn't work.

    In this case, activate the Wysija's cron option in Wysija > Settings > Advanced

    Cheers,
    Ben

  3. tinuviel
    Member
    Posted 1 year ago #

    Thanks for your help. I have requested the cron job be set up by my client's host. However, how come it worked before - and suddenly stopped? Why do I need to set up the cron job now, when it was fine before? Nothing else has changed in the settings, except a few plugin upgrades...

    Thanks!

  4. Ben
    Member
    Plugin Author

    Posted 1 year ago #

    Well,

    Good question!
    And the answer is "I don't know..."

    By default Wysija is relying on WordPress' cron system. This system is working but it has some mysterious behaviour once in a while, and it starts suddenly without notice or any clear reason.

    From what I read in various forums posts it has to do with some late scheduled tasks which sort of get the whole WordPress' cron stuck and that's when you guys come to ask us questions ;)

    People at Automattic created a plugin to sort all kind of wp-cron issues you can get : http://wordpress.org/extend/plugins/wp-cron-control/

    So at first we were asking our users to simply use that plugin to solve the problem, but as our plugin grew popular, more and more people started to have the same problem.

    Now, since that was a complex process to explain to our users, we've created the Wysija's cron option which seemed the simplest solution for you guys.

    1 - Tick the option
    2 - Save the settings
    3 - Eventually you'll need to set a cronjob but that's not even necessary depending on your site's traffic and your server's configuration.
    4 - And that should work!

    Hope this makes more sense.
    I personally think it doesn't :)

    Cheers,
    Ben

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.