WordPress.org

Ready to get started?Download WordPress

Forums

Fast Secure Contact Form
Emails arn't reaching my inbox when users fill in forms (4 posts)

  1. beORANGE
    Member
    Posted 1 year ago #

    Hello we have been using the plugin for a few years and have never had any issues with it. Recently we set up a new form and discovered that none of the emails that it was sending were actually reaching the desired inbox.

    It seems to be a problem with every instance of the plugin on the website (we have 10 of them)

    We are using an auto-responder on the form and this is working properly.

    Hope you can help resolve this issue.

    Thanks in advance
    Richard Barnes

    http://wordpress.org/extend/plugins/si-contact-form/

  2. hppwdn
    Member
    Posted 1 year ago #

    I'm having the exact same problem, http://www.miamiprivatetutors.com

  3. hppwdn
    Member
    Posted 1 year ago #

    Figured it out from some other posts on here. Dreamhost has updated to require all outgoing emails to be from an address on the domain.

    So in the Fast Secure Form Options for the form you're using you need to check the box for:

    "Enable when web host requires "Mail From" strictly tied to domain email account"

    and also manually type in a from address that is on the domain.

  4. heptagono
    Member
    Posted 1 year ago #

    I've solved it installing WP MAIL SMTP and keeping "Worpdress" as e-mail sender within Fast Secure Contact Form.

    More info: http://www.fastsecurecontactform.com/email-does-not-send

    Hope it helps!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic