WordPress.org

Ready to get started?Download WordPress

Forums

Emailing in posts using gmail (8 posts)

  1. SamF
    Member
    Posted 7 years ago #

    Hi all,

    I'm trying to set up a gmail account that I can use to email posts.

    • I created a new account, samf.blog@gmail.com (not the real address)
    • I enabled pop access
    • I set my Mail Server in 'Post via e-mail' to be pop.gmail.com, and my port to be 995
    • I put in my user name and password (I also tried including the @gmail.com in my user name)
    • I sent a mail to samf.blog@gmail.com
    • But nothing happened. What am I doing wrong? Is gmail not correctly set up to work with WordPress?

  2. Class
    Member
    Posted 7 years ago #

    I assume you log into pop.gmail.com:995 with a ordinary pop client?
    When logging into that gmail account, is the mail you wrote there? Just trying to find out if it was picket up or not.

  3. brianstanfill
    Member
    Posted 7 years ago #

    I think because gmail requires SSL authentication, the POP server will not authenticate wp-mail.php until it includes an option for SSL authentication.

    Can anyone verify?

    Incoming Mail (POP3) Server - requires SSL: pop.gmail.com
    Use SSL: Yes
    Port: 995

  4. brianstanfill
    Member
    Posted 7 years ago #

    I verified that I can successfully post via email using a POP server that does not require SSL authentication.

    Author = [removed]
    
    Content-type: multipart/alternative, boundary: ----=_Part_95115_29112534.1174289871014
    
    Raw content:
    
    Author: 1
    
    Posted title: testing email blog post
    Posted content:
    
    Mission complete, message 1 deleted.
  5. zappoman
    Member
    Posted 7 years ago #

    Couple suggestions... First of all, if you want to use the "Post via E-mail" feature built in to WordPress, then you have to use a POP3 server that is not running over SSL.

    Gmail only supports access to POP via SSL.

    So the first thing you need to do is to go find a wordpress plugin that support POPvSSL. A great choice appears to be "postie" which also supports a ton of other great features.

    Look for it here... http://postie.economysizegeek.com/

    Second, if you are having problems with this on a Win32 server machine, your problem may be related to these PHP bugs...

    http://bugs.php.net/bug.php?id=29036
    http://bugs.php.net/bug.php?id=36496

    Apparently php_imap.dll doesn't work with php_openssl.dll on Win32.

    The bug appears to have been fixed in PHP builds after Feb. 19, 2007.

    Good Luck.

  6. vshare
    Member
    Posted 6 years ago #

    blog via gmail works this way

    pop server : ssl://pop.gmail.com
    port:995

    rest the same

  7. akulavolk
    Member
    Posted 6 years ago #

    vshare, have you confirmed that ssl://pop.gmail.com works? I haven't been able to get this to work. Everything I've read about WordPress' blog-by-mail support suggest it doesn't support SSL, even if you list an SSL server for your POP server.

    Have you tried this and gotten it working? If so, what other software have you installed to get this to work?

    BTW, sorry to double-post here, but I noticed the comment from vshare in two threads. Since both threads come up in a Google search re: Gmail & WordPress posting, it's worth updating both. CC: http://wordpress.org/support/topic/119392?replies=2 Would really like to know if anyone's gotten this to work.

  8. jaso
    Member
    Posted 6 years ago #

    It looks as if you need the php method fsockopen() for php to get your email. Some web hosts disable that function, like mine does (grrrr).

    See this post.

Topic Closed

This topic has been closed to new replies.

About this Topic