WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
Email - WP Super Cache GC Report (7 posts)

  1. Hazman Aziz
    Member
    Posted 2 years ago #

    Hi,

    We have install and deployed WP Super Cache at http://blogs.ntu.edu.sg. It is a multi-site configuration.

    We get this email for all our blogs. We check the https://blogs.ntu.edu.sg/wp-admin/network/settings.php?page=wpsupercache&tab=debug. Nothing is check, but system is sending out this email.

    How can we disable this email from auto=post to all our users at http://blogs.ntu.edu.sg.

    Thanks,
    Hazman Aziz

    --------------------------------
    Hi,

    The WP Super Cache Garbage Collector has now run, deleting 0 files and directories.
    If you want to switch off these emails please see the WP Super Cache Advanced Settings page on your blog.

    Regards,
    The Garbage Collector.

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. Donncha O Caoimh
    Member
    Plugin Author

    Posted 2 years ago #

    It's an option on the Advanced settings page of the plugin under the Garbage Collection heading.

  3. admintiger
    Member
    Posted 2 years ago #

    I have WP Super Cache 1.1 installed at multiple sites. Two are test/development sites with public access blocked. The others are live. WP Super Cache sends an email each time its cache is preloaded even though "Send me status emails when files are refreshed" is not checked on its preload settings page. Emails are not sent from any of the other sites with identical settings.

    Deactivating WP Super Cache, deleting its directory, and re-installing doesn't correct the problem. That suggests that something was left set in the database by a previous version. Many incremental trunk versions of WP Super Cache, other plugins, and nightly WP builds have been installed at that test site over recent years, so database corruption is likely.

    I am not explaining this because the email issue is a problem for me. I could easily re-install everything in a fresh database. I just thought it is curious that only that one test site sends the emails and thought that fact might suggest to you another reason for the email issue described by Hazman Aziz.

  4. Hazman Aziz
    Member
    Posted 2 years ago #

    Yups, I can't reinstalled everything because I have more than 200 live blogs. The email are keep coming in.

    I have also unchecked all the Advanced settings page of the plugin

  5. Donncha O Caoimh
    Member
    Plugin Author

    Posted 2 years ago #

    Open up your wp-content/wp-cache-config.php and look for cache_gc_email_me. If it's set to 1 then change it to 0. That's what the settings page does and works on my blogs so I'm not sure why this happens to you.

  6. admintiger
    Member
    Posted 2 years ago #

    The wp-cache-config.php file at the test site that sends emails contains:

    $cache_gc_email_me = 0; //Added by WP-Cache Manager

    I checked to be sure the option isn't set a second place in the file with a different setting and found that it isn't.

  7. Donncha O Caoimh
    Member
    Plugin Author

    Posted 2 years ago #

    That's really bizarre. The only thing I can suggest is debugging the plugin. Use error_log wherever you find cache_gc_email_me and maybe there's some other plugin or code outside of the plugin setting it to 1.

    Failing that, just delete the wp_mail() command that sends the offending email but you'll have to do that again next time you upgrade.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic