WordPress.org

Ready to get started?Download WordPress

Forums

Email this stopped working (6 posts)

  1. DavidDeCristoforo
    Member
    Posted 8 years ago #

    After working fine for several days, my "email this article" link is broken. Now it just returns the following error:

    Warning: fsockopen(): unable to connect to mail.naturalfoodworks.net:25 in /home/naturalf/public_html/wp-includes/class-smtp.php on line 105

    Any ideas on what this means? The mail server seems to be working fine.

    Thanx
    DD

  2. MichaelH
    Member
    Posted 8 years ago #

  3. DavidDeCristoforo
    Member
    Posted 8 years ago #

    "This thread any help?

    No but thanx. My SMTP server settings are correct and valid as is the account that the wp-email file is configured to use. The whole thing worked fine for several days and then just stopped. Maybe I need to reload the files...

    DD

  4. MichaelH
    Member
    Posted 8 years ago #

    Antivirus program blocking port 25? Stretching here--Regarding server bindings?

  5. vkaryl
    Member
    Posted 8 years ago #

    Check with your hosting provider to see if they "upgraded" something....

  6. DavidDeCristoforo
    Member
    Posted 8 years ago #

    Got it working again by changing the SMTP server from "mail,naturalfoodworks.net" to "localhost" per my site support's suggestion. But I can't figure out why it stopped working just like that. They told me to use "mail,naturalfoodworks.net" in the first place! Anyway, it seems to be good for now...

    Thanx
    DD

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.