WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] "Email This" Spam Link Inserted into Posts! (13 posts)

  1. dworsky
    Member
    Posted 5 years ago #

    I just upgraded from 2.6 to 2.7, and when I made a new posting today, the "Stumble It" link that appears at the bottom of the post automatically was changed to "Email This" with a subject of "Supermodel Tyra Banks sizzles in the Heavenly 70 Bra and Diamond Heavenly Pendant" and contained a link within the body of the email to flickrlicio.us

    I don't know how this hack was accomplished... nor where it is buried in my code to remove it!

    (See http://www.mouseprint.org/?p=897 to view the link )

    Thanks

  2. whooami
    Member
    Posted 5 years ago #

    thats interesting. what plugin is responsible for creating that link?

  3. whooami
    Member
    Posted 5 years ago #

    also, using your ftp client, can you look at the directory and or files for that plugin, noting the permissions for all, AND the timestamps for all?

    any decent ftp client will allow you see to see timestamps and permissions.

  4. What a goofy web site. This background http://www.mouseprint.org/gifs/mouseback3.gif also made me laugh. Nice disclaimer that no one can actually read.

    The wget'ing the source code does not show that link. Looking at the source in Firefox also does not show that link either and in 15 seconds I missed any script references to display that.

    Also his footer says WP-Super-Cache but he's not using fancy permalinks. Goofy.

  5. whooami
    Member
    Posted 5 years ago #

    I saw it. you didnt see it?

    Many happy returns.

    [Do not click "email this" below ... is it spam!] <-- in red text :P

    Email this <---

  6. Oh. It's the feedburner link that's doing it.

    ht tp://feeds.feedburner.com/~s/MousePrint?i=http://www.mouseprint.org/?p=897

    Edit: sips more coffee (vacation good...) I saw it when firefox displayed it, was looking in the source for any blatant script, display:none, stuff.

    Many Happy Returns too :)

  7. whooami
    Member
    Posted 5 years ago #

    isnt that odd ...

  8. Dworsky, Feedburner is supposed to only feed what your site feeds to it (Ha, I kill me...).

    Your feed links

    http://www.mouseprint.org/?feed=rss2
    http://www.mouseprint.org/?feed=rss

    looks okay. It might be a Feedburner issue; I don't use feedburner so I can't tell you what is going on on the other end.

    If that link is in your single.php, you should comment it out. If it's via a plugin disable that. At least until feedburner returns the correct output.

  9. dworsky
    Member
    Posted 5 years ago #

    Guys...

    I do not have a single.php, and if it is coming from a plugin, I cannot tell which. I disabled the Buzzup plugin as well as the one that inserts Digg (diggclick)... but that did not remove the "Email this" link.

    Interestingly, I would think it has to do with Stumble it (that used to be in the spot where "Email this" appears. For the life of me, I cannot find the way I inserted the previous Stumble It link! (It is not in the theme's index.php, and I don't have a single.php where it normally would go.) I am beginning to think that maybe at one time I had a Sociable plugin, and enabled Stumble it throught that... but Sociable does not appear in my list of either enabled or not enabled plugins.

    UPDATE: Looking at Feedburner, in their "feed flare" service, "email this" was all of a sudden checked, and that was also the source of the Stumble It link that was missing all of a sudden. I will play with that to disable it (which is not yet working).

    ALSO: How do I enable "fancy permalinks" in 2.7 to make Super Cache work correctly?

  10. Either it's in one of your theme files or it's a plugin.

    Start by this: delete all your WP-Super-Cache files (use the button) and the disable all of your plugins. All of them, don't goof around.

    Clear your browser's cache and visit that page again and see if it's still there.

    If it went away it's a plugin. Do not turn on WP-Super-Cache, turn the other plugins on one at a time until the bad thing comes back. That will tell you which plugin needs to be deleted.

    If it's not a plugin, then switch to the default theme. If it went away then it's your theme. Make a backup copy of your theme and start looking for anything that has feedburner in it. Comment/delete that line.

    Good luck and Happy Holidays.

  11. dworsky
    Member
    Posted 5 years ago #

    JD...

    I got rid of it by commenting out the Feedburner code in index.php of the theme. Someone must have really screwed around at Feedburner to have caused this spam problem! Thanks for all the advice from you and others.

    Lastly... since someone mentioned a problem with my Super Cache (been wondering why it was not super caching pages...). How do I enable fancy permalinks?

    Thanks

  12. Good job re: feedburner.

    WP-Super-Cache needs fancy permalinks to work properly (or did, I have not kept up/used it since I moved to a fast host).

    Your Apache webserver will need to support mod_rewrite and let you use a .htaccess file.

    Go to your admin

    http://www.mouseprint.org/wp-admin/options-permalink.php

    and set the permalinks to what you like. Don't worry about the old links, the canonical feature in WordPress will let people click your old URLs and get sent to the correct URL.

  13. dworsky
    Member
    Posted 5 years ago #

    Thanks, JD, again.

    Edgar

Topic Closed

This topic has been closed to new replies.

About this Topic