WordPress.org

Ready to get started?Download WordPress

Forums

Email problems on IIS 6.0 server (6 posts)

  1. BlueCockatoo
    Member
    Posted 8 years ago #

    I could really use some advice here. I'm hosting on an ISP that uses IIS 6.0 and I'm not getting any emails from my installation of WordPress. As far as I can tell I have WordPress configured properly to send me emails when people make comments but they never come. I don't recieve errors so it makes it frustrating to debug. And unfortunately, I'm a newbie to PHP (but not programming) so I'm not sure where to begin looking.

    First, has anyone else had an issue like this on an IIS server and how did you resolve it?

    Otherwise, can someone tell me where I need to look in the files to see what's going on when an email should be triggered and how WordPress is using SMTP? Is there some kind of log I can look in that would have the "real" error?

    Any help greatly appreciated. This is my last issue to getting my blog up and running on this host!

    Thanks.

  2. skippy
    Member
    Posted 8 years ago #

  3. BlueCockatoo
    Member
    Posted 8 years ago #

    Thanks for that link. I haven't been able to get the plugin to send me the emails yet but I think it's a matter of configuration.

    Is there something I can do in WordPress to get it to attempt to send me emails OTHER than having fake comments? I am running out of IP addresses that I can have the comments sent from and I need some way to test this new mailer!

  4. basilv
    Member
    Posted 8 years ago #

    Thanks to your post, I just discovered that I have the same problem. For testing, you could change the Discussion options to always send an email when a comment is entered, and then just enter in comments.

  5. Chris_K
    Member
    Posted 8 years ago #

    I went down this road a while back, same issue. I had to give up on trying to use the localhost SMTP server for outbound email and, instead, just pointed to a different mail server. As I recall, that was in my php.ini file.

    [mail function]
    ; For Win32 only.
    SMTP = smtp.mycablecompany!.net
    smtp_port = 25

    Not a great "fix", but a serviceable workaround if you can do the same.

  6. basilv
    Member
    Posted 8 years ago #

    I'm running WordPress 2.0 on IIS 6.0, and had problems with not getting emails as well. Installing the wpPHPmailer plugin worked. Thanks for the help.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags