WordPress.org

Ready to get started?Download WordPress

Forums

Subscribe2
[resolved] Email notifications not received by gmail accounts (8 posts)

  1. GirlChild
    Member
    Posted 1 year ago #

    Hi

    I have been using Subscribe2 successfully until end Dec2012. At this point, email notifications (of new blog posts) stopped being received by subscribers with gmail email accounts.

    After reading on the forum, I changed the setting for emails from 0 to 1, but this doesn't seem to have solved the problem.

    I am not sure if the problem sits with gmail (who may be restricting the domain) but then I thought I'd receive a delivery error? This has been the case with other email service providers.

    Not sure if anyone else has the same problem?

    Any help would be most welcome!
    rgds
    African GirlChild

    http://wordpress.org/extend/plugins/subscribe2/

  2. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @GirlChild,

    Delivery errors are not always sent, especially if the message has been deemed to be spam for example, or if it has been silently dropped on your own server for some reason.

    Try installing a mail logging plugin to make sure the emails are generated and check out the spamminess of your emails by adding the following address as a public subscriber and looking at the report you get back when you make a new post.

    check@isnotspam.com

    Last thing to try is maybe raising this with your hosting provider or Google to see if your sever IP address has been flagged for spam messaging.

  3. GirlChild
    Member
    Posted 1 year ago #

    Thanks @Mattyrob - I'll give that all a try and report back.

    rgds

  4. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @GirlChild,

    Didn't mention this in my last post but these mail loggers work very well:

    http://wordpress.org/extend/plugins/email-log/

    http://wordpress.org/extend/plugins/wp-mail-log/

  5. SashainSydney
    Member
    Posted 1 year ago #

    Dear All,

    I think

    Settings > Miscellaneous > Barred domains

    blahblahgmail.com

    will also refuse subscriptions from

    myemail@gmail.com

    In other words, the blacklist doesn't seem to check the entire domainname.

    Do correct me if I'm wrong...

  6. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @SashainSydney,

    That is the way is works currently, It was originally written that way to account for subdomains such that entering "example.com" would block subscriptions from "1.example.com" and "2.example.com".

  7. GirlChild
    Member
    Posted 1 year ago #

    Ok all

    I installed email-log.

    Then sent another blog post.

    And still no notification received by gmail email addresses.

    However, it seems that is was delivered - kindly - directly to the spam folder.

    So, at least it was getting there, and I suppose it is up to gmail users to add the email address to contacts so that future emails aren't treated as spam?

    And you thought technology was here to make our lives easier ;)

    rgds
    African GirlChild

  8. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @GirlChild,

    The other thing you can try is subscribing check@isnotspam.com to your blog and you'll get a spam report for each of your emails. This can help to track down why your emails are being flagged as possible spam and you can take action to fix these issues.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags