WordPress.org

Ready to get started?Download WordPress

Forums

Cleverness To-Do List
[resolved] Email Assigned To-Do Items to User - Not Working (6 posts)

  1. paulpski
    Member
    Posted 1 year ago #

    Hello,

    The "Email Assigned To-Do Items to User" is set to "Yes" but when I create a task, assign it to a user and then "Submit the To-Do Item" it does not email the user.

    Please let me know what I can do to enable this functionality.

    Thank you!

    http://wordpress.org/extend/plugins/cleverness-to-do-list/

  2. Cindy
    Member
    Plugin Author

    Posted 1 year ago #

    That should enable it.

    I use WordPress's wp_mail function. Are you able to receive other emails that WordPress and/or other plugins send? I've heard some hosts do have problems sending emails from WordPress.

  3. Wirt
    Member
    Posted 1 year ago #

    I'm having this same problem, has there been any updates on this issue? I do get emails from other plugins.

  4. Cindy
    Member
    Plugin Author

    Posted 1 year ago #

    I have not been able to reproduce the problem on any of my test sites. This is only the second report I've received of it. Are there any error messages relating to the plugin in your server logs or any sort of additional info you can provide? What plugins do send mail correctly so that I can see their code to see if they're doing anything different?

    Settings-wise, List view must be set to either Group or Master. Under Advanced, Assign To-Do Items to Users must be set to Yes and Email Assigned To-Do Items to User must be set to Yes. You won't receive an email if you assign an item to yourself.

  5. Cindy
    Member
    Plugin Author

    Posted 1 year ago #

    Just a thought: The plugin uses the admin email specified in the default WordPress settings as the From address. I just read that if that address is from another domain, the host may not send the email. This is set is in /cleverness-to-do-list/includes/cleverness-to-do-list-library.php on line 312. I can add a setting to specify the From email address in the next version.

  6. Wirt
    Member
    Posted 1 year ago #

    That seems to be the issue, I changed it to send from my gmail and it worked.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic