WordPress.org

Ready to get started?Download WordPress

Forums

BuddyPress Group Email Subscription
email alert settings are never initialized for new users (2 posts)

  1. ydubois
    Member
    Posted 11 months ago #

    Hi

    A client of mine has been asking me to debug this plugin, because email alerts are almost never sent.

    In fact I discovered that the plugin mostly works fine. The problem is that user default settings are never recorded/applied until each user goes to her email alert settings screen and presses the "save" button.

    In other words, new users are not initialized. Existing users when the plugin is installed are not initialized either.

    This leads people to think that the plugin does not work at all, because the defaults "out of the box" settings do not work at all with existing or new users.

    For example, the array $ass_replies_after_me_topic is always empty if you don't go to each user's account setings for email alerts and click on the "Save settings" button. People expect to be alerted when people reply after them, because that's the default setting they see when they go to the settings page. They don't press the "save" button because the setting is already indicated as such. And so they are never initialized, this setting is never applied to them and they won't receive any alert.

    I did not see any code for initializing new or existing user settings, so I guess this is just a missing feature, but maybe I just did not find that code? Or do you plan on correcting this problem anytime soon?

    Thanks

    http://wordpress.org/plugins/buddypress-group-email-subscription/

  2. ydubois
    Member
    Posted 11 months ago #

    Here is a fix for this issue:

    https://github.com/yannbug/buddypress-group-email-subscription/commit/5a4bf1195d10ae92a2f726e19839a84cfcdf9f6a

    Please include it in the next plugin release, if possible!

    thanks

Reply

You must log in to post.

About this Plugin

About this Topic