WordPress.org

Ready to get started?Download WordPress

Forums

Email Address Linking Wrong (6 posts)

  1. cooper
    Member
    Posted 8 years ago #

    The posts on my email address are not doing the Mailto function. For some reason it is putting my url/example@example.com. It then sends the person back to the homepage. Any ideas where its adding the url part?

    I am using the K2 Theme.

    http://www.beenthereclearinghouse.com

    Thanks!

  2. techwench
    Member
    Posted 8 years ago #

    All the email links are showing up as mailto: links.

    BUT, you do have something wrong with your sidebar. Way down at the bottom of the page:

    Parse error: parse error, unexpected '}' in /home/beenthe1/public_html/wp-content/themes/beenthere/sidebar.php on line 11

  3. cooper
    Member
    Posted 8 years ago #

    Thanks, I understand there is an error in the bar, and am looking into that one.

    Most importantly the links aren't actually linking as mailto: For example, if you look at the latest post under sponser a family, you will see that the link is :http://www.beenthereclearinghouse.com/sponsor-a-family/tcklingensmith@yahoo.com
    not mailto: tcklingensmith@yahoo.com

    Any other advise you could give??

    Thank you so much.

    David

  4. You mean the email address linked from the commenter's name? Those are behaving oddly - looks like it's putting the value of the email address field into a link intended for the website address.

    You'll need to look in your theme's comments.php file to see what's happening there.

    If you'd like someone here to look, copy and paste the contents of the file here:

    http://pastebin.com/ (not into the forum, as that can be impossible to read) and post back here with the link the site gives you.

  5. cooper
    Member
    Posted 8 years ago #

    Hello,

    Thanks for your help, I pasted the comments.php file here:

    http://pastebin.com/376316

    Thanks so much!

    David

  6. techwench
    Member
    Posted 8 years ago #

    Your original post didn't say that it was happening in the comment author link.

    It's showing up like that because the url field is supposed to be used only for web urls.

    If "Emily" entered her email in the url field 1) that's not very smart with all the email harvesters for spam out there and 2) it'll format it for a web url.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.