WordPress.org

Ready to get started?Download WordPress

Forums

MailChimp List Subscribe Form
Email address field not translating (8 posts)

  1. hugoaap
    Member
    Posted 1 year ago #

    Hello! I'm attempting to update the Email Address field title in my WP/MC plugin form. I've changed the name of the field in the list to "E-mail" and since disconnected the plugin/re-connected it, clicked the Update List button in the plugin settings, and it still doesn't reflect the change. How do I get the field name on my plugin widget form to reflect the change?

    http://wordpress.org/extend/plugins/mailchimp/

  2. mc_tak
    Member
    Posted 1 year ago #

    Hey Hugo,

    That definitely sounds a bit strange. Would you be able to post a link to your page that has the sign up form, so I can take a closer look? The expectation is that using the "update list" button should have the field label show the most up-to-date information, so it definitely sounds a bit odd that you're seeing that not update.

    I look forward to hearing back!

  3. hugoaap
    Member
    Posted 1 year ago #

    Thanks, here, take a look: http://www.m2farma.com/novo

  4. hugoaap
    Member
    Posted 1 year ago #

    Hello mc_tak, any news about my issue? I try updating the list info but it doesnt refreshes the name field...

  5. mc_tak
    Member
    Posted 1 year ago #

    Hey Hugo,

    Thanks for providing me with that link. Through the form, I was able to identify the MailChimp account and take a closer look. In connecting your MailChimp account on my end to a local WordPress install, I was able to successfully connect the list in question, where it provided me with the correct field labe, "E-mail". Here's a screenshot of that: http://screencast.com/t/dZlBQFMQ

    This is definitely a bit odd, as I'm not able to replicate the issue in connecting the account on my end. It does sound like something may not be getting updated or re-connected properly, so we'll want to test a few things out.

    We would first ask that once more you ensure that you are clicking the "update list" button and receiving a success message at the top of the page (in WP-admin) notifying you that it has been successfully updated.

    Also, can you clarify whether any edits were made to the actual plugin code? Is it the most up-to-date version of the plugin? And have you attempted to uninstall and reinstall the plugin (I'm not sure if that's what was meant by reconnecting)?

    If all of the above has been done and you are still not able to resolve the issue, would you be able to try creating a new list, updating the email address field in that new list and seeing if those changes are apparent in your WordPress install, for that new MailChimp list?

    -tk

  6. hugoaap
    Member
    Posted 1 year ago #

    Hey guys, thanks for the support. I did have refreshed and reinstalled the plugin that time.
    Now i tried again, and it worked fine.
    The issue is solved. Thanks so much.

  7. elmstreet
    Member
    Posted 7 months ago #

    Hi, I have big problems translating the MailChimp plugin.
    Everything works pretty well but mails sent for confirmation are still in english.
    I tried to set french on my mail chimp settings but without success.
    On this page http://www.neversavenir.fr, there is a form to subscribe and I still get "Your Email Address" in the field though I'd like "Votre Email" in this place.
    Can you tell me how to do because, I really don't see how to manage this problem.

    Thanks in advance
    Gildas.

  8. mc_dominic
    MailChimp Support Rep
    Posted 7 months ago #

    Hi Gildas,

    Thanks for hopping in the forum. The confirmation emails will auto-translate according to the browser language that is set in your browser. So if the browser language is set to English when signing up, the confirmation emails will display in that language. You can manually translate those pages if you turn off auto-translate in your signup forms and change the translation from the Translate It Tab. This page has more information on translating the signup forms: http://kb.mailchimp.com/article/can-you-translate-my-signup-forms-response-emails/

    If you would like to change the place holder, a bit of the code for the plugin will have to be edited.

    -In wp-admin, go to Plugins > Editor > MailChimp > mailchimp_widget.php.
    -Locate this line of code:
    <input type="text" size="18" placeholder="'.esc_html($var['default']).'" name="'.esc_attr($opt).'" id="'.esc_attr($opt).'" class="mc_input"/>';
    -Change $var['default'] to $var['name']. This will begin using your field label as what appears in the placeholder attribute for your input fields.

    Now the placeholder will be whatever you have set for the Field Label in your sign up form. So if you visit the Signup forms page in your MailChimp list, change the field label for email to the text you want. Then make sure to update the list in the Plugin settings. One thing to note, these changes might be overwritten when the plugin is updated. So they will have to be reapplied.

    -mcd

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic