WordPress.org

Ready to get started?Download WordPress

Forums

Cryptex | E-Mail Address Protection
[resolved] email address cuts off (10 posts)

  1. dimensions111
    Member
    Posted 4 months ago #

    Thank you for making this plugin possible.

    I have autodetection set to ON for e-mails. When an email has two dots in the domain, the plugin only crypts the email address partially.

    none@level.hi.com
    is broken

    Any pointers to get phone numbers or custom fields crypted?

    https://wordpress.org/plugins/cryptex/

  2. Andi Dittrich
    Member
    Plugin Author

    Posted 4 months ago #

    Hi dimensions111,
    thank's for your feedback! this seems to be a bug of Cryptex' E-Mail-Autodectection feature. i will fix it as soon as possible.

    as a workaround, you can still use shortcode to protect your email-addresses like [cryptex]secret.address@sub1.mydomain.tld[/cryptex]
    this will also work for any custom text!
    if you want to use Cryptex into your WordPress PHP Template, you can use the function Cryptex::crypt('text to display as an image'); - it will output the given text as a single image.

    best regards, Andi

  3. dimensions111
    Member
    Posted 3 months ago #

    Hi Andi,

    Thank you for looking into the autodetection issue.

    The cryptex shortcode works nearly perfect!Great tip.

    I wrapped a shortcode with [cryptex][/cryptex] and still no works :/
    The shortcode itself is outputted as an image.

  4. Andi Dittrich
    Member
    Plugin Author

    Posted 3 months ago #

    Hi dimensions111,
    what do you mean with:

    I wrapped a shortcode with [cryptex][/cryptex]

    Did you try anything like this ? :
    [cryptex][othershortcode] text ... text[/othershortcode][/cryptex]

    something like this will not work yet, because cryptex can't render html which is maybe generated by another shortcode. Therefore "Nested Shortcodes" are not supported. Maybe their is another solution for you problem, what do you want to achieve ?

    best regards, Andi

  5. dimensions111
    Member
    Posted 3 months ago #

    Thanks Andi. I am using the following plugin to output custom fields in my theme.

    http://wordpress.org/plugins/custom-content-shortcode/

    I want to protect a custom field that contains a phone number (to stop harvesters and crawlers from gathering phone numbers on my website).

  6. Andi Dittrich
    Member
    Plugin Author

    Posted 3 months ago #

    Ok, that makes sense.
    Maybe i can add an option to cryptex which allows explicitly "Nested Shortcodes". It shouldn't cause any problems if the inner shortcode just returns text-content.

  7. dimensions111
    Member
    Posted 3 months ago #

    Really! Can't wait! :-)

  8. Andi Dittrich
    Member
    Plugin Author

    Posted 3 months ago #

    Hi dimensions111,

    i've added your Feature-Request to Cryptex v3.3 and fixed the Autodetection Issue as well. I hope this will work as excepted (you have to enable the "Nested Shortcode Option" under Settings -> Cryptex -> Advanced -> Nested Shortcodes (disabled by default)).

    You can download the latest Version from
    https://github.com/AndiDittrich/WordPress.Cryptex or
    http://wordpress.org/plugins/cryptex/

    Have fun! & best regards, Andi

  9. dimensions111
    Member
    Posted 3 months ago #

    Thanks a million! Are you accepting donations or?

  10. Andi Dittrich
    Member
    Plugin Author

    Posted 3 months ago #

    Don't mention it!
    Currently i can't accept donations..but you can rate the plugin/write a small review :)

Reply

You must log in to post.

About this Plugin

About this Topic