WordPress.org

Ready to get started?Download WordPress

Forums

Eliminating Meta Stuff From Displaying Under "More" Tag (7 posts)

  1. GadgetGuru
    Member
    Posted 8 years ago #

    I've searched for a solution, but have come up empty-handed...please don't flame me out if an answer to my question already exists. :)

    I have Bunny Tags running, and I've moved the "Posted To:" code to display at the bottom of each post. All of that works great. The problem is that I like my front page to display just a tease of each article, to prevent readers from having to scroll forever. I use the <!--more--> tag, which places the appropriate link to continue the article. Unfortunately, all of the Meta stuff (Bunny Tags, "Posted To:") still display under the "Continue Reading..." link. I'm certain that this can be remedied with a simple if/else statement in the PHP, but I know 3/10th's of f***all about PHP :(

    Can anyone give me a hand?

    Thanks in advance,

    GG

    P.S. Link to my site by clicking my Username. I didn't wanna spam up the place by including it in the post!

  2. GadgetGuru
    Member
    Posted 8 years ago #

    Anyone?

  3. vkaryl
    Member
    Posted 8 years ago #

    I know less than you about conditionals in php, so can't help either. Did you check to see if there's an article in the codex about it? http://codex.wordpress.org/Main_Page, then use the search box, or start with Advanced Topics from the sidebar.

  4. Joni
    Member
    Posted 8 years ago #

    I must not understand the OP's question because it seems to me that if he modifies single.php (which is where the "more" link takes you, right?) he can achieve what he wants by just stripping the meta info out of the single.php template?

    J

  5. vkaryl
    Member
    Posted 8 years ago #

    I don't know Joni - I never use the "more" stuff myself....

  6. estjohn
    Member
    Posted 8 years ago #

    I have used the bunny tags on mine as well.. though I used post teaser plugin to automatically do the excerpt for me on the main page..

    so in my main.php i have
    <?php the_content('&raquo; Read the rest of this entry...'); ?>
    <?php the_bunny_tags(); ?>

    then on the single.php i have the same thing, only the whole post shows with the bunny tags because the_content sees its on a single page (from the post teaser plugin)
    i beleive is how/why it worked on mine using that..

  7. GadgetGuru
    Member
    Posted 8 years ago #

    Thank you for the responses.

    vkaryl:
    Yes, I tried searching for about 30 minutes.

    jonimueller:
    To make things a bit more clear: I'm using a modified version of the fmulti theme, which has no "single.php", . I guess I could create a "single.php", and just include the Bunny Tags & Posted To meta there, and remove it entirely from "index.php". I guess I was just hoping there was an easier solution than having to create a page and figure out how to include it in the loop.

    estjohn:
    Yes, that's what my code looks like, as well. When I was using the Crimson Milk theme, it worked perfectly. I'm guessing that this is because CM has a "single.php" in the heirarchy.

    Again, I appreciate each of you taking the time to try and help me out.

    If anyone knows of a solution other than creating a "single.php" page, please let me know!

    Thanks,

    GG

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags