WordPress.org

Ready to get started?Download WordPress

Forums

[Elegant-Grunge] image frames (4 posts)

  1. washeranddryer
    Member
    Posted 2 years ago #

    Hi Folks. I've noticed that in elegant grunge, images are put in frames, which is fine most of the time. But I would like to have certain images without frames, or even certain pages that don't have frames around the images.

    I've searched around on the internet and not been able to find a solution. The thread for this topic on this forum was closed after the poster figured out the solution--but she/he didn't post it!

    So, any help would be appreciated! Thanks! My knowledge of web programming is not extensive, but I'm picking it up as I go along.

  2. michaeltyson
    Member
    Posted 2 years ago #

    Hey =)

    You have a couple of options - if you have control over the image markup, add the class "noframe" (class="noframe") to the image tag. If not, and if the image tag has a class already, put that class name in the "Don't frame images with class" setting for the theme.

    Otherwise, if you don't have direct control over the image markup, and the image tag doesn't already have a class attribute, then you'll need to dip into the code that generates the image tag and modify it directly.

  3. Drawer2
    Member
    Posted 2 years ago #

    Is there any way for me to write to michaeltyson, member above, directly? He invented Elegant Grunge theme, and I have been looking for an answer for over a month. I posted my question elsewhere, but briefly, my custom fields - post-meta-data -- show only in my main page, but not on individual posts.

    I have moved several variations of the meta to single. php, function php and index php. I'm wondering if the special image frames somehow stop the custom fields from appearing.

    Any help? My blog: http://chocolatecartoons.com/

  4. Drawer2
    Member
    Posted 2 years ago #

    Update. I fixed my custom fields by deleting some lines in single php. In other words, like most of what I do here, I experimented, trial and error.

    In single php, had to delete:
    <?php wp_link_pages(array('before' => '<p><strong>'.__('Pages', 'elegant-grunge').':</strong> ', 'after' => '</p>', 'next_or_number' => 'number')); ?>

    (which was old navigation???) and it appeared. I have no idea what this means, btw, but then the post-meta showed up.

    In the end, I didn't want it at the bottom of the post, so I have it on the top!

Topic Closed

This topic has been closed to new replies.

About this Topic