WordPress.org

Ready to get started?Download WordPress

Forums

WP-Spreadplugin
[resolved] Either 502 error or API error (11 posts)

  1. daniellev
    Member
    Posted 2 months ago #

    Hi Thimo,

    I have a curious problem: I just moved my website, because the previous host had many server issues. But now I've reinstalled Spreadplugin and when I try to open the page with the webshop a number of things can happen:

    1. I get a 502 Proxy Error like this: Proxy Error

      The proxy server received an invalid response from an upstream server.
      The proxy server could not handle the request GET /index.php.

      Reason: Error reading from remote server

    2. I get a css-less layout of the website, stating I have to check my API or shop id
    3. I get a server time out message

    After checking this entire forum, I decided to limit the amount of articles to check if that would help and it actually did: with only 80 items activated it did load the shop as it should. Re-activating the items and clearing the cache made all off the errors above happen again off course.

    However I have over 200 items in my shop, which I would like to display.

    Is there any way to make that happen? Maybe filling the cache in some sort of steps (like adding 50 items at a time)? Or refreshing the page like 20 times in a row...?

    I hope you have a solution for this, because it is kind of frustrating :( Thanks in advance for your response!

    https://wordpress.org/plugins/wp-spreadplugin/

  2. Thimo Grauerholz
    Member
    Plugin Author

    Posted 2 months ago #

    hm, did you try to load the articles again after getting a timout? sometimes it helps.

    you may also try this:
    http://stackoverflow.com/questions/7739870/increase-max-execution-time-for-php

  3. daniellev
    Member
    Posted 2 months ago #

    Thimo, thanks for your quick reply! I did try to reload them, got 502 again... I'll look into the link you gave, will update as soon as I can share some results.

  4. daniellev
    Member
    Posted 2 months ago #

    Hi Thimo,

    I've made the changes to my wp-config.php as mentioned, but it didn't lead to anything. Keep getting 502 now (most of the time, got 1x the page that suggested I should check my shop-id).

    Got any other suggestions?

  5. daniellev
    Member
    Posted 2 months ago #

    Hi Thimo,

    I didn't give up, so I have continuously been refreshing the page since my second-last post (one hour ago). Somehow that did the trick: after an entire hour of hitting F5 the entire cache got refilled, so I'm fine for now.

    However, it doesn't seem solved yet: I don't feel like doing this every time I add/delete an article or change a price. So I would greatly appreciate it if you could look into this a little more. Maybe it is possible to load the products in some sort of 'portions' if 50? That would involve some mouseclicks, but not an hour or so hitting refresh...

    I look forward to your answer.

  6. daniellev
    Member
    Posted 2 months ago #

    Hi Thimo,

    Didn't clear the cache or anything, but suddenly it gives me the page with "Error getting articles. Please check Shop-ID, API and secret." again, or it 502's on me again. The problem is ongoing I'm afraid... So if you can help me out here, I would be really greatfull.

  7. Thimo Grauerholz
    Member
    Plugin Author

    Posted 2 months ago #

    maybe 3.6.2 may help you :)

  8. daniellev
    Member
    Posted 2 months ago #

    I had deactivated the plugin alltogether, since it made it impossible to load the page properly. But I will give it a new try, thanks Thimo!

  9. daniellev
    Member
    Posted 2 months ago #

    It didn't help, keep getting multiple 502's before it finally loads the shop. And it does that on every page of the shop, so I disabled it again. But if you figure it out, please let me know, because I do love the plugin, it seems it just can't handle a lot of shirts... :(

    Thanks anyway though!

  10. Thimo Grauerholz
    Member
    Plugin Author

    Posted 2 months ago #

    please activate debug mode in spreadplugin (in settings) and send me the url please

  11. daniellev
    Member
    Posted 2 months ago #

    Hi Thimo,

    I will do that, just not right now, because I'm running some ad campaignes and as soon as the plugin is activated and the cache needs to be filled, it slows down or even gives a 502 on the other pages too.

    My shop concerns the Dutch, and focusses on the WC Soccer right now: I can't afford any downtime right now.

    But thanks again, I will contact you when the rush is over ;)

Reply

You must log in to post.

About this Plugin

About this Topic