WordPress.org

Ready to get started?Download WordPress

Forums

Editor monkey causing errors (8 posts)

  1. akmac
    Member
    Posted 8 years ago #

    HI all,
    I'm using Safari, so tried to install editormonkey in order to be able to view A toolbar for adding links/pictures/and such. After uploading and activating it, I'm getting:

    Warning: Wrong parameter count for class_exists() in /home/whatever/public_html/new/wp-content/plugins/editormonkey.php on line 15

    in the header and:

    Warning: Cannot modify header information - headers already sent by (output started at /home/margaret/public_html/new/wp-content/plugins/editormonkey.php:2) in /home/margaret/public_html/new/wp-admin/inline-uploading.php on line 138

    In my Write Post page. So, I went back to the puligins page to deactivate it, and it isn't showing!

    How do I fix this mess? Thanks!

  2. mod_mephisto
    Member
    Posted 8 years ago #

    I received the same error message:

    Warning: Wrong parameter count for class_exists() in /home/infidelw/www/www/counterpoints_blog/wp-content/plugins/editormonkey/editormonkey.php on line 15

    Warning: Cannot modify header information - headers already sent by (output started at /home/infidelw/www/www/counterpoints_blog/wp-content/plugins/editormonkey/editormonkey.php:15) in /home/infidelw/www/www/counterpoints_blog/wp-admin/plugins.php on line 16

    Help!

  3. mod_mephisto
    Member
    Posted 8 years ago #

    The above-mentioned lines are these...how should they be changed?

    if ( !class_exists("editormonkey", true) ) {
    class editormonkey {

  4. rajkp
    Member
    Posted 8 years ago #

    Hey guys, sorry about the error. The second parameter only exists in the PHP5 version of the class_exists()

    It's been removed, so it's now
    if (!class_exists("editormonkey")) {
    // yada....

    Or you could just delete this if (and the bracket at the very bottom corresponding to the end brack for the if), as this check is only necessary on some servers.

  5. mod_mephisto
    Member
    Posted 8 years ago #

    OK, I've tried to follow your instructions (thanks!), but now a host of other error messages are popping up!

    After playing with it, this is what I have:

    Parse error: syntax error, unexpected T_STRING in /home/infidelw/www/www/counterpoints_blog/wp-content/plugins/editormonkey/editormonkey.php on line 23

    And this is what the file looks from line 15-23:

    */
    (!class_exists("editormonkey"))
    //class editormonkey

    // PHP 5 constructor

    /*** OPTIONS **/
    // Add the default options for using EditorMonkey if they don't exist
    add_option('editormonkey_use', 'true', 'Automatically use the WYSIWYG interface');
    add_option('editormonkey_overrideusers', 'true', 'Force all users to use the plugin settings');

    Thanks for the Help!

  6. mod_mephisto
    Member
    Posted 8 years ago #

    I updated editormonkey.php according to the file on your website. It generated these error messages.

    Warning: Cannot modify header information - headers already sent by (output started at /home/infidelw/www/www/counterpoints_blog/wp-content/plugins/editormonkey/editormonkey.php:968) in /home/infidelw/www/www/counterpoints_blog/wp-login.php on line 9

    Warning: Cannot modify header information - headers already sent by (output started at /home/infidelw/www/www/counterpoints_blog/wp-content/plugins/editormonkey/editormonkey.php:968) in /home/infidelw/www/www/counterpoints_blog/wp-includes/pluggable-functions.php on line 274

    Warning: Cannot modify header information - headers already sent by (output started at /home/infidelw/www/www/counterpoints_blog/wp-content/plugins/editormonkey/editormonkey.php:968) in /home/infidelw/www/www/counterpoints_blog/wp-includes/pluggable-functions.php on line 275

    Warning: Cannot modify header information - headers already sent by (output started at /home/infidelw/www/www/counterpoints_blog/wp-content/plugins/editormonkey/editormonkey.php:968) in /home/infidelw/www/www/counterpoints_blog/wp-includes/pluggable-functions.php on line 247

  7. spicycauldron
    Member
    Posted 7 years ago #

    I don't recommend anybody install Editor Monkey. It's one thing to install, quite another - a nightmare - to ever remove.

    See this post:

    http://wordpress.org/support/topic/60382?replies=6

    Editor Monkey wins 'most intrusive plugin of the century' award and is a real pig to remove. But it can be done!

  8. rajkp
    Member
    Posted 7 years ago #

    EditorMonkey is neither intrusive nor a bitch to uninstall.

    1) Use the link provided in the plugin description to deactivate EM and remove it from the database.

    2) Reset "Use rich editor" from your User Profile page.

    That was easy. What do people find so hard about that?

    The hard way:
    1) Deactive the plugin.
    2) Reset "Use rich editor" in the Options > Writing page.
    3) Reset "Use rich editor" in the User Profile page (per user setting).
    4) *OPTIONAL* Go into the database and remove any option begin editormonkey_ or em_.

    As you can see, EM creates its own settings so as not to interfere with the other settings.

    [Edited: namecalling is uncalled-for and contra the regs].

Topic Closed

This topic has been closed to new replies.

About this Topic