WordPress.org

Ready to get started?Download WordPress

Forums

Editor broken after upgrade to 3.3? (23 posts)

  1. dale_c
    Member
    Posted 2 years ago #

    I upgraded to 3.3 this morning. Now if I go back and try to edit an old post, the editor screen is blank. If I use my mouse and highlight the entire editor box, I can see the HTML code but it is not working the way it did prior to the upgrade.

    I have tried changing themes to no avail. Is anyone else experiencing this issue?

  2. Jonas Grumby
    Member
    Posted 2 years ago #

    Have you tried deactivating all plugins?

  3. dale_c
    Member
    Posted 2 years ago #

    Yes, I meant to mention that in my original post. Disabled all plugins, tried reverting back to default them, and no change, still a blank editor window when I try to edit a previous post.

  4. Jonas Grumby
    Member
    Posted 2 years ago #

    Other people have reported the same or a similar problem. Unfortunately IDK the answer but you can read lots of other threads about it, particularly ones that are marked Resolved.

  5. Make sure you've read the entire Master List post and the New Features in 3.3 Post.

    Go to your own install's about page - http://domain.com/wp-admin/about.php - to see what's new.

    And then make sure you've tried...

    - flushing any caching plugins you might be running, as well as server and/or browser caches.

    - deactivating all plugins (yes, all) to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s). If you can't get into your admin dashboard, try resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems. Also remember to deactivate any plugins in the mu-plugins folder. The easiest way is to rename that folder to mu-plugins-old

    - switching to the Twenty Eleven theme to rule out any theme-specific problems. If you can't log in to change themes, you can remove the theme folders via FTP so the only one is twentyeleven. That will force your site to use it.

    - manually upgrading. When all else fails, download a fresh copy of the latest.zip file of 3.3 (top right on this page) to your computer, and use that to copy up. You may need to delete the wp-admin and wp-includes folders on your server. Read the Manual Update directions first!

  6. dale_c
    Member
    Posted 2 years ago #

    Thanks Ipstenu, I have tried everything you mentioned with the exception of doing the upgrade again manually. Will try that this afternoon and report my results back here.

  7. dale_c
    Member
    Posted 2 years ago #

    Ok I have tried all the suggestions above. I even rolled back to the previous version of WordPress (running in a VmWare environment) and did the 3.3 upgrade manually and I still have the same issue, the "edit" box for previous posts is blank unless I select the box with the mouse then I can see what's there.

    Same thing with trying to add a new post, I can enter a title for the post but cannot see anything in the edit box.

    I guess I will wait and see if anyone else runs into this issue.

  8. hapzfl
    Member
    Posted 2 years ago #

    yes, I have; and I created another thread on this issue

  9. Samuel Wood (Otto)
    Tech Ninja
    Posted 2 years ago #

    And then make sure you've tried...

    - flushing any caching plugins you might be running, as well as server and/or browser caches.

    I can't emphasize that part enough. Really, clear your browser cache and restart the browser. It's amazing how strongly some browsers will hold onto old JS code.

  10. hapzfl
    Member
    Posted 2 years ago #

    I have tried it with IE9, Firefox 8, and Chrome: always the same unpleasant result.

  11. dianaf86
    Member
    Posted 2 years ago #

    @Otto is right about flushing your browser cache. I had a 3.3 error and reverted back to 3.2.1 and was having this same problem this morning. Just tried again from my work computer and my visual editor works fine. Will be clearing my browser cache when I get home.

  12. Dale_Reagan
    Member
    Posted 2 years ago #

    This seems to be the same similar problem I encountered with 3.2.. :(

    http://web-tech.ga-usa.com/2011/07/wordpress-3-2-may-break-your-site/

    - suggested solutions did not work for me
    - I 'rolled back' to 3.2.1...

    http://wordpress.org/download/release-archive/

    It would be nice if the 'auto-update' had a 'auto-revert'...

    :)
    Dale

  13. dale_c
    Member
    Posted 2 years ago #

    Like a lot of folks on other threads, I was able to resolve this issue by installing the "Use Google Libraries" plugin.

    Seem like a round about way to solve the issue to me but hey, it works.

  14. hapzfl
    Member
    Posted 2 years ago #

    dale_c, thanks for the hint, IT WORKED !

  15. Dale_Reagan
    Member
    Posted 2 years ago #

    Based on the description/notes this may provide a 'fix' where you:

    a) enable the plugin (and test for everything working) followed by
    b) disable the plugin (which should cause your server to 'serve' updated Javascript to your browser, i.e. 'fixing' the problem.)

    "Allows your site to use common javascript libraries from Google's AJAX Libraries CDN, rather than from WordPress's own copies."

    http://wordpress.org/extend/plugins/use-google-libraries/

    Note that there may be performance or other advantages for using the plugin so you could just run it until/unless it causes a problem, i.e. if the Google CDN goes 'down' - probably not very likely...

    I will give this approach a whirl on with a multi-site install...

    :)
    Dale

  16. If the problem is fixed by using Google Libraries (which I use and work nicely on Multisite, by the way), then the problem's your cache :/

  17. Dale_Reagan
    Member
    Posted 2 years ago #

    After just a little testing with the 'use google plugin':

    a) using the 'plugin' seems to 'fix' 3.3

    b) if I dis-able the plugin then 3.3 is 'broken' again

    Given the above I will speculate that WordPress 3.3 javascript changes 'broke' something...

    I will guess that 3.3+ will hopefully have a 'fix'...

    :)
    Dale

  18. Parneix
    Member
    Posted 2 years ago #

    The Google Librairies plugin fix the very same problem for me. Prior to try it, I did try everything (really) Ipstenu suggested, including emptying my browser cache. Nothing worked. But everything was fix by the Use Google Librairies plugin.

    I hope this problem will be fixed soon. Shouldn't have to rely on an external plugin (one more) to get the very basic operation in WordPress work.

    P.

  19. The fix is to get your browser to actually do it's job and flush the cache :/ It's ... this shouldn't happen. Browsers are violating their principles.

  20. Parneix
    Member
    Posted 2 years ago #

    Hi,

    Thanks for the input. Basically, you're saying that with the release of WordPress 3.3 all browsers are suddenly “violating their principles”?

    Isn't there something new with the way WordPress handles javascript?

    P.

  21. dale_c
    Member
    Posted 2 years ago #

    For what it's worth, I disabled the Google plugin and then connected to WordPress with a browser on a freshly installed system - same issue. This leads me to believe that it's *not* a browser cache issue....

  22. Parneix
    Member
    Posted 2 years ago #

    The best info I could find on that issue is at the link below. There are multiple suggestions to fix the problem, including a “hot fix” by WordPress.

    http://wpgeniusbar.com/blog/2011/wordpress-3-3-upgrade-problem-toolbar-disappears-in-pagepost-editor/

  23. dale_c
    Member
    Posted 2 years ago #

    Thanks for the link Parneix, the hotfix solved the problem for me.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.