WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Editing Permalinks for a multisite (10 posts)

  1. gan35h
    Member
    Posted 2 years ago #

    Hi,

    I have a multi-site: site1.local.loc [with subdomains on my local] and I would like to have three pages on this.

    site1.local.loc/works - (posts page, but I want 'Works' as my title)
    site1.local.loc/about - (static page)
    site1.local.loc/contact - (static page)

    Since 'Works' is my posts page where I keep putting in content, I changed my permalinks for this site to:

    /works/%postname%/

    However, when clicking on 'view post' at the end of posting anything, it leads me to a '404' page which means there is a disconnect.

    How do I solve this? Also how do I make all my posts appear in my 'Works' page (as in, how to make that page the posts page?)

    Thanks!

  2. You made a page called /works/ right? Does that work on its own?

    I wonder if there's a conflict with a page AND a permalink definition...

  3. gan35h
    Member
    Posted 2 years ago #

    Actually, now the situation is that any static page I make shows a 404 error. Any new blog I view shows a 404 error. I'm quite certain that these pages exist :(

    For now, only my home page loads.

  4. Right-oh!

    This is related ;)

    Turn off pretty permalinks and use fugly. Does that work? If so, try one of the default options (yyyy/mm/dd/postname) and see if THAT works. If not, it's a .htaccess or httpd.conf problem :)

  5. gan35h
    Member
    Posted 2 years ago #

    I tried the 'month and name' permalink. No change. Still 404 not found. How do I solve my .htaccess issue/conf issue?

    The default permalinks seems to solve the problem but any other permalink means a definite 404 not found page for anything other than the home page.

  6. Check your httpd.conf file and see if you set AllowOverrides to all.

    And make sure you edited your .htaccess correctly for MultiSite.

  7. gan35h
    Member
    Posted 2 years ago #

    Must I set this to All in my httpd.conf?

    # AllowOverride controls what directives may be placed in .htaccess files.
    # It can be "All", "None", or any combination of the keywords:
    # Options FileInfo AuthConfig Limit
    #
    AllowOverride None

    In other places in httpd.conf, I found these:

    <Directory />
    Options FollowSymLinks
    AllowOverride None
    Order deny,allow
    Deny from all
    </Directory>

    <Directory "D:/ganeshv/Apache2.2/cgi-bin">
    AllowOverride None
    Options None
    Order allow,deny
    Allow from all
    </Directory>

    I had copied whatever WordPress gave me at the start of the multisite installation. This is the current content for .htaccess

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]

    What changes must I make?

  8. Where you have AllowOverRide to NONE you need to change that to ALL. That's telling your local install that you don't want to let it use .htaccess redirects.

    However which ones, I would say ... all.

    .htaccess looks fine, so it's clearly not being read, which means it's the httpd.conf.

    Bear in mind that you're using Windows, and there should be some directions on how to set it up for local webserving. I know MAMP comes with directions .

  9. gan35h
    Member
    Posted 2 years ago #

    Quite amazing Ipstenu. Your solution worked! Again! Thanks a million!

  10. Jason
    Member
    Posted 2 years ago #

    Thanks! "AllowOverride All" for .htaccess fixed my issue!

Topic Closed

This topic has been closed to new replies.

About this Topic