WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Editing pages link in dashboard leads to 404 error (31 posts)

  1. reganfrank
    Member
    Posted 3 years ago #

    Hi,

    This is a weird problem install of WP 3.0.1.

    When ever I try to:
    1. Create a new page (/wp-admin/page-new.php) , or
    2. Edit an existing page (/wp-admin/edit-pages.php)

    I get a 404 error! If thats not weird enough, every other link ie Media library / Posts etc in the admin panel works fine! I seems that the two offending URLs are the only two that cause this error.

    I thought that maybe this had to do with my .htaccess file, but I have copied it perfectly from the wordpress codex page. Here it is anyway, just incase:

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    # END WordPress

    Could somebody have a look and let me know it Im goin a little batty :)

    Thanks

  2. reganfrank
    Member
    Posted 3 years ago #

    **Workaround**
    If I go to the dashboard and click on the Pages (/wp-admin/edit.php?post_type=page) in the "Right Now" tab, I am taken to a list of pages and am able to add / edit pages from there.

    But this I'm sure is not normal.

    Can you help?

  3. but I have copied it perfectly from the wordpress codex page.

    Why not copy it perfectly from the menu in your own install? The codex page is *an example*. When you set up the network, you are given commands to paste in specific to your own site.

  4. If that doesn't work, what's your actual URL?

  5. reganfrank
    Member
    Posted 3 years ago #

    you are given commands to paste in specific to your own site.

    Oops. I must have missed that page on the network install!! grrr

    Anyway I can "re" get it?

    ipstenu - my url is http://sharetel.com.au/

  6. Your site comes up as being in maintenance mode,... And not the normal default one.

    If you can get into the wp admin section of your main site, you should be able to get to the tools -> network menu. There it'll have your htaccess settings.

  7. you are given commands to paste in specific to your own site.

    Oops. I must have missed that page on the network install!! grrr

    Anyway I can "re" get it?

    really? It;s the second page and has two huge boxes that say what to do.

    Go to Tools -> Network. they will still be there. Read the entire page.

  8. Slamlander
    Member
    Posted 3 years ago #

    @Andrea: I did the auto-upgrade and that should have caught it. It keeps wanting to do '/wp-admin/edit-pages.php' Also, ReganFrank's workaround to 'wp-admin/edit.php?post_type=page' doesn't always work.

    Right now, the page editing features are broken and we need them fixed!

    * I am self-hosted under Win2Kserver, IIS 5.0, and PHP 5.1.4.

  9. Do a manual upgrade then. I've seen the auto-upgrade not quite complete and look like it did.

    And you're on IIS. I have no idea if that's related, but it could be.

  10. Slamlander
    Member
    Posted 3 years ago #

    Actually, I downloaded the zip file and that doesn't contain the missing files either. Elsewhere, I was told that edit-pages.php was refactored into edit.php. Obviously the link wasn't changed to match. IOW, it's a bug, not a feature!

    Calling the wp-admin/edit.php?post_type=page instead of the wp-admin/edit-pages.php sort of proves this.

    3.0.1 desperately needs a bugfix release or at least a patch. Tell me where the link is generated and I'll fix it myself. Thank you.

  11. Elsewhere, I was told that edit-pages.php was refactored into edit.php. Obviously the link wasn't changed to match. IOW, it's a bug, not a feature!

    Which link?

    I cannot reproduce this on a clean install of WordPress. Maybe you have a plugin for the admin section that's causing this?

  12. Elsewhere, I was told that edit-pages.php was refactored into edit.php.

    Where?

    3.0.1 desperately needs a bugfix release or at least a patch.

    If it's been out this long and these are the first we're hearing it.... something else is wrong, not a bug.

  13. Slamlander
    Member
    Posted 3 years ago #

    According to MacManX (http://macmanx.com/)

    http://wordpress.org/support/topic/wp-301-is-broken?replies=4

    It's not been out that long and this isn't a feature that is used that often. Most sites don't change their page structure that much.

  14. I just checked - that file was removed in 3.0 & you should be redirected. So... find out what links to it, specifically.

  15. Slamlander - If you could tell us WHERE, exactly, you see those erroneous links, it would help us help you :)

    I can't find 'em, but I'm sure my search was not exhaustive.

  16. Slamlander, you probably had an incomplete upgrade, as nothing should be linking to that file.

    Try downloading WordPress again and delete then replace your copies of everything except the wp-config.php file and the /wp-content/ directory with fresh copies from the download. This will effectively replace all of your core files without damaging your content and settings. Some uploaders tend to be unreliable when overwriting files, so don't forget to delete the original files before replacing them.

    If that doesn't work, it's possible that a plugin or theme function file could be causing it to appear, so try deactivating all plugins and switching your theme.

  17. reganfrank
    Member
    Posted 3 years ago #

    really? It;s the second page and has two huge boxes that say what to do.

    Andrea_r - I did copy this, but still had the same problem! Thats why I tried out the Codex instructions. I am still a noob. And appreciate the help. Thanks

  18. @regan have you read the handy dandy ebook I whipped up? :)

    http://wpebooks.com/2010/09/how-to-enable-multisite-in-wordpress/

  19. Slamlander
    Member
    Posted 3 years ago #

    Okay; From the Dashboard, left column (aka side bar)
    Pages = http://slamlander.caselle-vpn.net/wp-admin/edit-pages.php = 404
    Pages->Edit = http://slamlander.caselle-vpn.net/wp-admin/edit-pages.php = 404
    Pages->Add New = http://slamlander.caselle-vpn.net/wp-admin/page-new.php = 404

    James: I am trying your suggestion now (after making backups, of course) However, this server is on my same LAN and I am not using an uploader. I am writing directly to the network share at 100Mbps. Repository and operations files are on two different RAID1 arrays.

    I should mention that I am having this same problem with all 10 of my websites and NONE of them share files. I do not use the MU capabilities.

    I'll report results here later, bon soireƩ

    PS: I should mention that I create and modify pages via LiveWriter, under Vista Ultimate. The only limitation of that method is that it cannot delete pages. That's when I ran into this.

  20. Okay; From the Dashboard, left column (aka side bar)
    Pages = http://slamlander.caselle-vpn.net/wp-admin/edit-pages.php = 404
    Pages->Edit = http://slamlander.caselle-vpn.net/wp-admin/edit-pages.php = 404
    Pages->Add New = http://slamlander.caselle-vpn.net/wp-admin/page-new.php = 404

    Woudl you like a screenshot of 3.o? There is no Pages -> Edit link in the left side menu in 3.0. There's just Pages and Add New.

    If you're on 3.0, then you're either running a plugin that adds it, or you're not completely upgraded.

    I do not use the MU capabilities.

    then this should have been in a new thread in a different forum section.

  21. Not to mention that those URLs don't match what I see on four different installs of WP, Multi and non-Multi.

    Not a bug, something's wrong with your install.

  22. and you're on a windows box...

    For reference, here's trac , you can read thru the code yourself.

    http://core.trac.wordpress.org/browser/trunk

  23. Slamlander
    Member
    Posted 3 years ago #

    @Andrea: Considering that I have a suspect 3.0.1 and have no clue what the new screen is supposed to look like, YES! I would love a screenshot.

    I've spent the last day getting dental work done in France and too high on pain-killers to log in as root. Off to do the reinstall now. (Another long story that involves having to know French, Dutch, and German to get the job done right *sigh*)

    PS: There is nothing wrong with having a Windows 2000 Server. Linux does not do Active Directory. But under Windows, you are better off with IIS than Apache.

  24. Slamlander
    Member
    Posted 3 years ago #

    I found the bastidge!!

    I did as John suggested and did a manual re-install. No joy there.
    Then I deactivated ALL my plugins. Lo and behold, the Pages submenu changed it's links to the reported new values!

    I then reactivated each plugin one by one until the links became FUBAR again.

    The dirty little bastidge is: CMS-Like Admin Menu v 2.1

    I've been using it reliably for years. What do I do now? I sort of need it. That's why I've been using it.

  25. No, I'm sure a Windows server is fine. It's just that in quite a number of cases, it's a lot more difficult to get this running. :)

    http://www.flickr.com/photos/andrea_r/5099012209/

  26. Slamlander
    Member
    Posted 3 years ago #

    Thanks for the screenshot but it's (sort of) fixed already. It least we know the color of the bug, the number of legs, and even the species.

    Now, what do I do for the CMS functionality?

    For my blog, it isn't a problem but the others don't want posts on their front pages. :(

  27. I didn't see your post when I posted. :D (darn caching)

    There is a built in setting to set a page for the home, and not the posts. Under settings -> Reading.

  28. Slamlander
    Member
    Posted 3 years ago #

    Okay and all is good. It looks like CMS-Like Admin Menu v 2.1 is obsolete anyway.

    Thanks all.

  29. mttd
    Member
    Posted 3 years ago #

    i too am having the same issues...an auto upgrade from 2.8.1 that has screwed up the pages links...real pain. I guess I will just have to do a manual reinstall OOH...sigh...

Topic Closed

This topic has been closed to new replies.

About this Topic