WordPress.org

Ready to get started?Download WordPress

Forums

editing pages adds "-2" to my permalink (8 posts)

  1. northcoastimports
    Member
    Posted 3 years ago #

    I just updated all of my WP installations to 3.0.4.

    They all work, except at http://www.northcoastimports.com

    Now, when I go back to edit a page, the permalink changes. It automatically adds a "-2" to the end of the permalink.

    Of course, this screws up my existing links. The links generated by WP are okay, but any that I put in manually still refer to the old one...

    for example:

    When I edited this page:
    http://www.northcoastimports.com/cc/8dm/8365

    it changed the permalink to:

    http://www.northcoastimports.com/cc/8dm/8365-2

    How can I turn that off??

  2. You cannot have a duplicate post slug. The slugs must be unique.
    Since you already have http://northcoastimports.com/cc/8dm/8365/ , another page with the same slug automatically gets "-2".

    Try editing the slug manually to something else (that is not used in any other post).

  3. esmi
    Forum Moderator
    Posted 3 years ago #

    Also try emptying your Trash in case the original post with that slug is still sitting in there.

  4. northcoastimports
    Member
    Posted 3 years ago #

    Thanks.

    I don't have more than one page with the same slug. I don't have a http://northcoastimports.com/cc/8dm/8365/ page - that's getting re-directed to the parent (http://northcoastimports.com/cc/8dm/)

    As soon as I edit any existing page, it automatically adds the "-2" as if it's creating a new page instead of editing the old.

    I don't have anything in Trash.

    I've tried naming it something else, which works, but then try naming it back to "../8365" and I get the "-2" automatically added again.

    Any idea what I can do?

  5. northcoastimports
    Member
    Posted 3 years ago #

    UPDATE: Apparently, it only occurs when the permalink is a number. I just created a new test page with the permalink "test" and it worked okay. I also created a new test page with the permalink "9999" and it added a "-2"

  6. Ah!
    Sorry, I missed that you are referring to a Page not Post.
    You can't use 4-digit slugs for Pages. This is to avoid conflict with yearly archive URLs. (e.g. http: http://northcoastimports.com/2010/)

  7. northcoastimports
    Member
    Posted 3 years ago #

    Thanks so much for your answer!

    Is this new to the latest version of WP? I never had this problem before... I've been happily naming all of my pages with 4 digits for about a year.

    Is there any way that I still can use the 4 digits? Perhaps with a different permalink setting? Otherwise i'l have to change all of my pages and their links ... There are over a hundred!

  8. northcoastimports
    Member
    Posted 3 years ago #

    It also happens with long numbers with lots of digits (more than 4)

    As long as there is one letter it doesn't seem to happen.

    I'd really like it to work with digits and not have to add letters. Is that possible? It worked fine before for like a year.

Topic Closed

This topic has been closed to new replies.

About this Topic